Stepper Not Moving - Only High Pitch Noise/Twitch

Hello. Got everything built out and wanted to test a single stepper motor before advancing, but got stuck. Below are the components and steps I took to test things out. Not sure if I am missing a step or what but I’ve tried every combination for the motors. I did have them working with an Arduino/CNC Shield for a XY Plotter if that helps any.

Hardware/Software :

  • Archim 1.0a -
  • Hanpose 17HS4401 NEMA Stepper Motors - Aliexpress Link
Troubleshooting Steps:
  • Hooked up power - Logic and Stepper ports
  • Flashed the firware successfully.
  • Hooked up LCD screen
  • Hooked up single X axis stepper
  • Used LCD controller to try and move motor (not attached to belt).
  • Went through every combination of wire connections. Cut power between attempts.
    • I would get a high pitched noise and/or a slight twitch or even nothing at all.

You need the previous version of the Archim firmware. The current one has an issue I am trying to figure out.


One from the V1 Github? Or somewhere else?

I have added this link to the firmware page.

Thanks, this solved my motor not moving issue. But now I cannot get both x or y motors to move together. Does it go X1 Y1 Z1 Z2 X2 Y2 from left (starting on side with usb) to right (side with power)? Or do they need to split off X1 and Y1?

You have to edit the config_adv to enable Dual endstops. I just popped a board trying to figure this out, probing for signals. I have one left, hopefully I figure this out soon.

Is it just uncommenting the line below to use 2 X drivers? Sorry for the questions but I didnt want to ruin anything if avoidable.


I was able to get the 2 X steppers working, but when I went to do the same for Y I got the error saying something like there wasnt enough E slots available. Not sure if this is going to help but I went tot he pins_Archim1.h file and added the lines below replacing what was there for E0 and E1. Should this work without breaking anything if it compiles?


#define E0_STEP_PIN 100 // PB23 STEP3 * DUAL
#define E0_DIR_PIN 99 // PB26 DIR3 * DUAL
#define E0_ENABLE_PIN 101 // PB24 EN3 -Addons * DUAL

#define E1_STEP_PIN 78 // PB23 STEP3 * DUAL
#define E1_DIR_PIN 22 // PB26 DIR3 * DUAL
#define E1_ENABLE_PIN 97 // PB24 EN3 -Addons * DUAL

#define E2_STEP_PIN 26 // PD1 STEP4 * DUAL
#define E2_DIR_PIN 27 // PD2 DIR4 * DUAL
#define E2_ENABLE_PIN 28 // PD3 EN4 * DUAL

Sorry I forgot about all the other changes.

That should be the previous Dual.


I am still working on the new branch, there are more issues. Actually working on it right now.

Is it a general problem with the firmware on Github?

I am having a similar problem with the following setup:

  • Arduino Mega 2560
  • Ramps 1.6 with DRV8825 drivers
  • Wantai 42BYGHW811-X1 2.5A stepper motors
  • Full graphics LCD display
  • Marlin-MPCNC_Ramps_T8_16T_LCD_32step firmware
I can feel the heatsink on the drivers getting hot when trying to move axis through the UI, but I only get a high pitched noise from the stepper motors, but no movement.

I don’t think so, likely just the 32bit versions are suffering. I’m running with a Mega and Ramps v1.4, dual endstop - no issues so far.

As for your specific situation, more information is needed.

Have you tried moving the steppers without the belts connected? Did you set vref on the drivers? etc.

Is there supposed to be relatively little sound (meaning high pitch noise) when running? The noise remains even after stopped until I restart the LCD.

Did I F up getting the Archim 1.0a?

Yes, they all make noise depending on what part of the sine wave it is being held at. Have a look at the singing 3D printer videos if you want reassurance.

Just a quick update.

I ordered my stepper motors with connectors and mating cables.

I had a spare stepper motor from the same company (Wantai), identical model (42BYGHW811) that I had been using for another project with a Arduino UNO and a stepper motor shield.

I wanted to test the new motors in the same setup and wired them directly to the motor shield using male-male Dupont connectors.

Same result as with the MPCNC setup: The motors just stuttering and no turning.

I noticed that the colors of the wires were identical on the spare motor as well as the MPCNC motors, so I re-arranged the wires to match the spare motor - and sure enough, the motors now turned as they should.

Back to my dry-run MPCNC-style, I can now turn the stepper motors using the UI. SUCCESS.

Grats! I’ve been in the “industry” for many years and I’m still learning (good thing?). I didn’t realize that there was a “standard” color code for stepper motors. Do your Wantai motors follow one of the color patterns in the attachment? Most of us use bi-polar (4 wire steppers) I’m guessing. Good for future reference if/when someone encounters this issue.


There isn't a standard color code for steppers. Sometimes you just get lucky.

Yep. Looks like I jumped the gun, upon further searching - it varies quite a bit between manufacturers, which I thought was the case originally. I’ve purchased steppers in the past and most come with a magic decoder ring that tell you which wires are which.

At least we know another thing to look for next time a builder has a stepper motor problem.

No, definitely not a common standard for the wire colors, as have been pointed out here and elsewhere on the internet.

Having said that, it appears that Wantai uses the upper one (Red, Blue, Green, Black) on their stepper motors.

I forgot to mention that my spare motor had fixed wires, as opposed to the set I bought for the MPCNC, which had connectors.

The fixed wires made me wonder, and wanting to try to re-arrange the wires on my set.