Stepper Motors Weak

I’ve been using MPCNC por a couple of years now, with inconsistent results. Most of the time I get missing steps, even with very conservative cuts. I think the steppers are a little weak, since I can move them by hand without much force when energized.

I’m cutting plywood mainly and some acrylic, so there should be no problem, but sometimes I get missing steps even a low speeds (1000mm/min) and 2mm deep passes.

I have Nema 17 Stepper Motors (1,7A 0,59Nm 83,6 controlled by an RAMPS 1.4 with A4988 Drivers. I have Vref set to the max (1.7V) → meaning in this drivers that I have 1.7A : Smart choose of the reference resistor.

I also measured the current going to one of the motors, and to my surprise it was exactly 1.7A at max, so I’m running the steppers at the max binary.

For power I use the 12V from the PC controlling the MPCNC. The PC power Supply says it can deliver 30A at the 12V output, so I don’t think there’s a problem with that.

How can I add more force to the motors? Maybe new stronger ones, or better drivers?

I am surprised that 1.7A would still be weak.

I have practically never skipped steps (except when doing something really dumb) with my Primo, with the steppers at 950mA. (Current chosen to keep the motors below about 45°C.)

I might suggest that your motors may be the culprit, if you sourced your own. Do you have the part number or specifications for your motors?

I am still using the same setup as you it appears. But I have the voltage reference set at .75 volts. It is very difficult to move the steppers by hand when enabled. At one point early on I thought I would gain " more power" by increasing current to 1.5V. I losed most of the holding power and steps were erratic. I went back to the ‘sweet spot’ of .65 to .79V. I never really messed with it more. My guess is that the overcurrent and over temp controls had something to do with it… Other than measuring the holding current of one of the coils, it is difficult to measure the true current of the coils without a very good scope.
I also remember that the steppers got very hot when enabled with the higher current.
I’m not sure how you are getting the 12V from your computer. But I would check again and make sure your getting 12V at the ramps board connector when running.

I bought the cheapest ones in Amazon :crazy_face:. 17HS19-2004S on the sticker. In the seller page says the same. I also tried lower currents, mainly at the first runs, but it failed a lot. Completely unusable.

With 1.7A the motors get a little hot, but not much, I kept them at 1.7A since they don’t get very hot and the results are better.

A number of builds have come across the forum with your same electronics (Ramps + A4988), and the same stepper motors purchased off Amazon. They are not having your issues (running at less current), so you might want to look beyond the electronics and steppers to see if there is some other issue:

  • What is the feedrate you are using for your cutting? Using too fast (and sometimes too slow) a feedrate can cause issues.

  • What is the depth of cut you are attempting? Start with something shallow like 2mm then increase it.

  • Have you checked the grub screws that hold the pulleys to the stepper motors? Historically this is a common root cause of slippages.

  • Is your wood or your bit or wood burned? Getting the wrong speeds and feeds will quickly burns bits making it too dull to cut effectively.

  • What bit are you using? I suggest you start with a 1-flute, upcut bit.

  • What RPM setting are you using with your Router? For most bits and woods, you don’t want to be running your router at full speed. You can take a look at the chart for the old Shapoko to get an idea of the RPM setting for your Makita router (though I would start with a shallower DOC than the chart). Your feeds and speeds will vary from this chart, but this chart will give you a starting point.

  • Any chance you used steel reinforced timing belts? If so, the steel will break running over the pulley resulting in inconsistent stretching.

  • How easy do your axes slide when the steppers are off? They should slide smoothing with little resistance.

  • Are you sure both steppers and each axis are working consistently? Wiring issues can cause a stepper to lose steps.

  • Make sure your router is turning clockwise. While I’ve never seen this issue with a Makita router (it happens with spindles), it only takes a few seconds to check.

Note that I can easily overwhelm my engaged steppers, but I don’t suffer from lost steps. Also, I’m concerned about your high current setting. I’ve never seen a “stock” Primo run this hot. My concerns are the stepper motors getting too hot and melting the PLA plastic, plus running hot can cause the stepper drivers to shut down temporarily.

1 Like

This may or may not play any role in your issues, but you might want to clean those tubes and bearings up a bit. The rust could be adding unnecessary resistance.

I tried cut at 2000 mm/min with some success. Also tried at 1000 mm/min with same results, and 2mm / pass. The wood is not burned, but it’s coming like dust, not chips. I know it’s wrong, but I have to keep the feed rate low not to miss any steps. Also no reinforced belts, since I cut them when assembling.

When the steppers are off I can move everything with ease. The steppers are connected correctly. If I run the program away from the plywood, it runs without any issue.

I’ll try the following:
Check the grub screws that hold the pulleys. Didn’t thought about that.
Adjust the RPMs according to that table! I was running it full speed (30K).
Reduce the current to around 1.2A?!

There are a few things to keep in mind:

The maximum feedrate for Z is significantly slower than the maximum feedrate for X and Y. Looking at rapids (non-cutting moves), V1 recommends starting at a max of 2100 mm/min for X and Y and 480 mm/min for Z. I don’t know what CAM tools you are using, but these limits can be set in some CAM/postprocessor solutions. In addition, they can be set in the Marlin firmware using an M203 g-code. Note if you are moving too fast on Z (and therefore losing Z steps), you will cut deeper which will lead to lost steps on X and Y.

This video by Winston Moy is the first place I began to put together how RPM, Feedrate, and flutes need to work together. While not producing as nice a finish, a single flute upcut bit will be the most forgiving for dialing in the feeds and speeds. Reducing your RPM should allow you to cut shavings instead of producing dust.

The torque of the steppers drops off as the speed of the stepper increases. You may buy some added torque at rapid speeds by powering your steppers at 24V rather than 12V. An increase in voltage will not make a difference at cutting speeds.

The general recommendation is to go deeper rather than faster. I recommend you do some test cuts in MDF. Try cutting a square and a circle at a DOC of 2mm, 4mm, 6mm and maybe 8mm. Start your speeds slow (300 or 400 mm/min) and walk up to 1000mm/min.


I cut white oak at 500 mm/min and cherry at 800 mm/min and pine at 600 mm/min at 4mm depth of cut 40 % stepover all day long doing a ramp in 10 to 30 mm I can run faster but this is so reliable i hate t o mess with perfection. Also gooi g deeper is a option but most of my cuts don’t need the extra depth to keep layers even

Just to give an update, I followed your suggestions:
. Check the grub screws that hold the pulleys. Those where ok
. Lowered the current to 1.2A
. Reduced the feed speed and RPM to the material

It seems to me, I’ve underestimated the material hardness. With plywood I can go to around 2000 mm/s without any problem but I need to go to much lower speeds cutting acrylic, but even that needs to be tested before going to the final pieces, since some acrylic are much harder than another. I figured out that the problem was on the RPM and feed speeds since I managed to break the cutting bit.

With acrylic is much harder to find a good RPM / Feed combination, because if I go too slow, it’ll melt and be stuck to the bit. Even changing one brand to another I need to lower or raise the RPM and adjust the feed. I’m doing this, starting at 1000mm/s and increasing or lowering the feed in the OpenBuilds.

I think the problem wasn’t with MPCNC, but with my lack of knowledge in using it.

Thanks everyone for your help and suggestions. Those really made a difference.

1 Like

for acrylic Trochoidal works well. I cut full depth in one pass. Helps keep the bit cooler and gives a clean cut

Chant with me: Trochoidal, trochoidal. Hoohaa.

What do you use to make the Trochoidal path?

Assuming you are using Estlcam…

In the bit settings you can set up Trochoidal. Click the wrench icon to the left of which ever bit you want to use.


How much stepover depends a lot on what you are cutting, how stiff your machine is, how fast your feed rate is. I have found for aluminum 5% stepover and 25mm/s works good. In acrylic I can go 10-15% stepover. And I always cut full depth.

Soon ill be doing some testing in 1/2" aluminum and will post my results