Stepper Motors not moving

Hi I just built my mpcnc but the stepper motors don’t move but do sometimes a very sharp noise. I’m using a Ramps 1.4 board and the A4988 drivers, also a 12v 30 amp power supply.

If you anything please help.


Which firmware, and pictures please.

1 Like

Hi thanks for replying, I’m using the MPCNC_Ramps_T8_16T_LCD_32Step but I’m not using an LCD


What have you tried? How are you trying to move them?


Your question doesn’t provide any information to work from.

I’m not home right now so I don’t pictures right now but I think I burnt my drivers y plugged them the wrong way around.


From the information you have provided, I think the issue your having is that your trying to run 1/32 micro-stepping on a A4988 which can only do a max of 1/16 micro-stepping. I don’t have a lot of experience in this area yet but maybe someone else can chime in on this.

I run A4988 stepper drivers and this wouldn’t cause the problem. It should still move, it would just move twice the expected distance. Although if it’s fried from plugging backwards, or disconnecting while energized, then of course that’s a problem.