SKR V1.4 Turbo Dual endstops and adding a Z touch plate

Is it possible to use this pinout to run the z touch plate on the skr v1.4 turbo and what would have to change in the pins file and configs file to make it work?
Im already using the z-stop, y-stop, x-stop, e0det and e1det pins for the endstops now.

1 Like

Normally the Z end stop is the probe.

But im using that endstop for the dual z endstop or am im thinking wrong

Looks like it is defined in the pins file:

So you need to enable using that pin, I think, and then turn off the “z probe uses zmin” option. Then it should show up in M119 and you can use G38.2 to probe it.

Sweet I’ll give it a try and let you know the results.
Thanks Jeffeb3 once again you pull thru!

ok in config.H I did this :


#define Z_MIN_PROBE_PIN P0_10 // Pin 32 is the RAMPS default WAS TURNED OFF

I then upload the bin file and connected to RH
20:34:04.976 : Cap:SERIAL_XON_XOFF:0
20:34:04.976 : Cap:BINARY_FILE_TRANSFER:0
20:34:04.976 : Cap:EEPROM:1
20:34:04.976 : Cap:VOLUMETRIC:0
20:34:04.976 : Cap:AUTOREPORT_TEMP:0
20:34:04.976 : Cap:PROGRESS:0
20:34:04.976 : Cap:PRINT_JOB:1
20:34:04.976 : Cap:AUTOLEVEL:0
20:34:04.976 : Cap:Z_PROBE:0
20:34:04.976 : Cap:LEVELING_DATA:0
20:34:04.976 : Cap:BUILD_PERCENT:0
20:34:04.976 : Cap:SOFTWARE_POWER:0
20:34:04.976 : Cap:TOGGLE_LIGHTS:0
20:34:04.976 : Cap:CASE_LIGHT_BRIGHTNESS:0
20:34:04.976 : Cap:EMERGENCY_PARSER:0
20:34:04.976 : Cap:PROMPT_SUPPORT:0
20:34:04.976 : Cap:AUTOREPORT_SD_STATUS:0
20:34:04.976 : Cap:THERMAL_PROTECTION:1
20:34:04.976 : Cap:MOTION_MODES:1
20:34:04.976 : Cap:CHAMBER_TEMPERATURE:0
20:34:05.007 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
20:34:05.007 : echo:DEBUG:INFO,ERRORS
20:34:05.007 : Begin file list
20:34:05.007 : End file list
20:34:05.023 : echo:Unknown command: “M80”
20:34:05.023 : echo:Unknown command: “M221 S100”
20:34:05.023 : echo:DEBUG:INFO,ERRORS

Next I home all axis’s, then did a M119 and got this:
21:09:26.867 : Reporting endstop status
21:09:26.867 : x_min: TRIGGERED
21:09:26.867 : y_min: TRIGGERED
21:09:26.867 : y2_min: TRIGGERED
21:09:26.867 : z_min: TRIGGERED
21:09:26.867 : z2_min: TRIGGERED

then i ran a G38.2 and got this:
21:11:03.855 : N15 G38.2*58
21:11:03.871 : echo:Unknown command: “G38.2”

do i need to enable #define G38_PROBE_TARGET?

Yeah. I think there’s something else we are missing. Something that tells it you have a probe…

I think FIXED_MOUNTED_PROBE is probably it.

1 Like

ok in config.H I did this

and in configadv.H I did this
#define G38_PROBE_TARGET

I then upload the bin file and connected to RH

then ran the m119

then ran the g38.2 z-20
and it moved z axis down slowly and touch the plate and stopped.
i then ran g92 z15.19 (15.19 is the thickness of the plate that is as using.)
then raise the Z axis 30mm and then ran G1 z0 and it touched the top of the work piece spot on!!! :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face:
it freeakin worked!!! omg THANK YOU again Jeffeb3!!!

so now i have dual y and z and single x axis endstops along with a z probe that i now can probe x y z axis to get a X0 Y0 Z0 on my work piece!

I hope this info will help others with the same skr board or similar boards work!!
Thanks again!
Rob H aka Crash13


Moved to a different thread