SKR ProV1.2 firmware update

On trying to update the firmware on the Btt SKR Pro v1.2 using the usual sd card it wouldn’t update( file wouldn’t change from .bin to .cur). So, I tried the method of using a st-link to load a bootloader, which seem to complete correctly going by the pc screen.
So, I tried inserting the sd card again, still nothing!

So, the question is, is there another way of flashing the firmware to this board without using the sd card? And if so, could you please give me a rough idea what is involved, please?

Many thanks in advance

I have had a few SKR boards that didn’t change from .bin to .CUR and it still actually flashed. You can check on the screen to see the firmware name and it also shows when it was updated. I don’t have one set up anymore or I would post pics from the screen.

Hello, Paul.

Let’s do a bit more troubleshooting of your setup.

When you’re flashing firmware on an SKR, it’s the bootloader doing the work not Marlin.
For the bootloader to flash a new Marlin, there’s a few prerequisites:

  • you must be using an SD card that is formatted FAT32, and not greater than 32Gb in size.
  • the card must be in the SD slot on the SKR, not in the SD slot in the LCD.
  • “High speed” cards seem less reliable for flashing than slower (I keep a class 4 card around just for this kind of work.)

Because of the variations amongst SD cards, it’s worth trying a different SD card even if the one you are using meets all the items above.

It might help to see a picture of your setup in case any other details become obvious to us.

Which firmware are you trying to flash, and for which machine type?

The sd card is a 2gb standard Sandisk.
It is formatted as fat32.

I have to admit I haven’t checked to see if it has updated other than if the file change from .bin to .cur.

The board is fitted to a Creality CR10 s pro v2 with a bbt tft35 v3 screen.

Which I’m also having problems with not displaying other than the 2 option, marlin or touch.

Do you have a machine with a sender that you can attach via USB to the CR10?
It would be helpful to see the results of an M503 command to Marlin.

The best way to try and cut this problem in half would be to unplug the cables from the SKR board that go to the LCD, and try re-flashing without the LCD hooked up. Then troubleshoot the LCD after you get the flash completed.

If you can get that M503 response back from Marlin it would be helpful to troubleshoot.

Before the firmware flash I had octoprint working on this machine but since the flash octoprint has lost connection to the printer

That starts to call into question whether the bootloader was successfully flashed at all.

From Octoprint, when the SKR is plugged in and turned on, do you see any dmesg output when you connect the CR10?

E.g. do the following:

  • open a terminal or SSH connection to the octoprint host.
  • Plug in the USB between the Octoprint host and the CR10
  • Type the following and report back what you get from Octoprint

sudo dmesg | tail -n 10

It comes back with message’: ‘Unable to connect\nOnce the underlying issue is corrected, use the\n"FIRMWARE_RESTART" command to reset the firmware, reload the\nconfig, and restart the host software.\nError configuring printer\n’, ‘error’: ‘WebRequestError’}

That’s what you get trying to press the “Connect” button in Octoprint.
This isn’t the needed diagnostic information, which was:

The Octoprint host doesn’t see anything at all when the USB cable is plugged in.
My guess at this point is that your attempt at flashing the bootloader corrupted the bootloader.

You’ll need to work on reflashing the bootloader if you are going to recover this board.

There’s a thread here in the V1E forums about how to do this:

Edit to add: Since you previously tried to flash a bootloader, you might want to double check that you returned all the jumpers on your SKR board to the proper position afterwards. Failing to do so would also leave you in a no-boot scenario.

That’s one reason I suggested you share a picture of your setup in the replies up above.

Many thanks for your time and patience. It was much appreciated.
I will have a look at the link you provided and work through it and hopefully, I will get this printer up and running.

Good luck.
Please let us know how it turns out and feel free to keep this thread going if you can use additional support.

I had another go with the STM32 St link utility and flashed the firmware and bootloader to the SKR board as shown:-

I got the firmware and bootloader from this website well rather GitHub as shown:-

But still no connection with Octoprint!

I have now got the Mobo to accept the Firmware.bin file via sd card.

but, still no joy in either Octoprint or the screen yet!

That’s a good start. It’s still possible there’s something wrong with Marlin- where did you download Marlin from?

Can you repeat the test with getting dmesg results from Octoprint after you’ve plugged in the SKR?

I re installed Octoprint and it now connects properly. So, I suppose it’s the screen to sort out now!

This is what I’m getting now

Still no sign of life from Marlin. Those dmesg entries are the tail end of your last boot, then nothing.

You could try a different USB cable, or plug in some other USB device into the Pi (To prove your USB cable/port is working correctly).

Since you’re now able to get firmware on the card to flash, let’s focus on making sure you have the correct version of Marlin for your printer. I’m not familiar with the CR10 options, so it’ll take a bit of research. Where did you download Marlin from?

One more thing to check: On the SKR, there is a jumper that sets whether the microcontroller gets power from USB or from the board power.
When installed in the printer, you need that jumper to be in the position where it gets power from the printer, or things won’t work. Let’s double check that.

It also wouldn’t hurt to grab some compressed air and blow that board off thouroughly.

1 Like