SKR Pro 1.2 with TFT not connecting to computer

I have my SKR Pro 1.2 with TFT working via touch screen for moving the Lowrider2. However I cannot connect to the board with my windows 7 64 bit computer. It is not recognized as a usb device and it does not show up with arduino IDE or repetier.

  1. Tried 2 different USB cables
  2. Tried all ports on laptop
  3. Orange light is on next to the USB cable
  4. I have re-flashed the firmware twice
  5. Device is showing up under “other devices” in my device manager with a yellow exclamation mark.
  6. I have tried restarting the computer and board
  7. When I connect to the computer it says “device driver not successfully installed”
  8. I have tried it with and without the SD card installed
  9. Jumpers are on “USB” on the board
  10. Here are my settings in repetier, there is no options in the “port” drop down menu.

    Any ideas?

It probably needs drivers. We haven’t seen many windows 7 machines with this board, because it is a lot newer than windows 7.

edit: sorry i didn’t see it was for skr Thanks for pointing that out Ryan

Does the Rambo driver work for an SKR?

1 Like

Yeah the driver does not work for the SKR, I also can’t seem to find any drivers online specific for the SKR board

have you tried this one? its for skr pro v1.1. might work for v1.2


That did it! thanks redneckmudrat!

lol no worries

I need to link that in the instructions. Thanks Mike.


Hi RobP - I have the same issue, assuming I am a newbie and I have the correct driver for SKR Pro 1.2 do I have to reflash my SKR Pro board to to get the USB on the TFT35 to work? If so are there instructions on that process and is there anything needed to be done to the TFT35?

Thanks Glenn

Hi Glenn, welcome.

This is a two year old thread. It would be best to start a new one of your own and please let us know where you got your board from, what kind of computer you are using, and what you have tried.

Ok, thank you - I can now make a new thread.