SKR pro 1.2 locked up. I’m not sure what I did

I finally tried getting my SKR board working after having it about a year. I connected everything per directions and nothing was really communicating so I figured I should flash the firmware with the latest version. Everything went well, but I still had the comm problem, but I could at least get the stepper motors to vibrate. So I had the idea to reflash the firmware again. Just because. After that the board just locked up and will not respond to anything. The 3 yellow LEDs are on and the blue D11 LED when I insert the SD card. The reset button will not reset the SKR board and I can’t flash the firmware. The reset button on the SKR board will reset the TFT35 though. The screen of the TFT35 is black and just says Marlin Mode at the top. A 3 second press of the knob will get me to touch screen mode, but there seems to be no communication with the SKR. Any ideas?

oh wait, I steered someone down a bad path before with shaking stepper, turned out there stepper was not wired correctly and was fighting itself. please ohm check and verify your wiring.

what config is this dual endstops, dual steppers, or series wiring?

It is series wired, I am trying to keep it as simple as possible. My next step was to check the stepper wiring, so I did the z axis and rewired it. Now I can’t get my SKR board to do anything, not even flash new firmware or reset.

I fear the bootloader may need reflashing. I did it once, from Linux and it wasn’t super easy. I flashed it over uart. There may be easier instructions in windows.

I’m not sure what causes it. I am a bit fast and loose when flashing and I was flashing a lot (I was testing new firmware versions) when it happened to me.

Another time, it seemed to be in a similar situation, but it was fine after I plugged it back in the next day. So maybe try to flash it a few times before looking at the bootloader.

1 Like

That is all new territory for me, but I will give it a try. The funny thing with mine is that I seemed to be making progress, then called it a night and the next day it was hung up. Like the opposite of your situation, lol.

I use windows, so I will see what I can figure out. Hopefully someone will read this and have some advice, as right now I am like a monkey looking at a chessboard, haha.

EDIT: Can someone point me towards whatever adapter I will need to install the bootloader for my SKR from windows? I have looked through several posts and see people using all kinds of ST-Link adapters. Some big, some small, some with different names. I really am a newbie at this, so please bear with me. lol. I am just looking for the correct adapter that I can get cheap off Aliexpress.

Can you please send me a screenshot of the files you have on your micro SD card (SKR Pro), and what you have on the SD card (screen).

Neither the board or the screen reflashes? Are your cards formatted fat32?

The screen reflashes fine, and I was able to get the SKR to reflash at least once, but no longer. I just reformatted my SD card and reinstalled FIRMWARE.bin and tried again, but still the same. No flashing green LEDs and no change to the file extension.

Is the micro SD seating all the way in? I have one that I need to hold the micro SD in while it flashes.

Another thing to try is unplug everything and try just USB power, make sure to swap the power jumper.

I tried powering from USB and making sure the SD is seated, as well as providing different angles of pressure and there is no change. Question: shouldn’t the LEDs on the SKR flash or do something when the reset button is pressed? If I press the reset button on the SKR, the TFT resets and the screen goes off but absolutely nothing happens on the SKR. The 3 green LEDs and blue SD LED never blink or anything.

It does sound like you have a corrupt bootloader. That’s pretty rare with most modern 32bit uc’s. I’d guess it’s defective, but that doesn’t help 1yr after purchase. An ST-Link programmer needed to attempt fixing the bootloader is not that cheap ($12 MIC clone or $35 oem), it takes a decent amount of footwork getting all the software and knowing how it’s used, and it is not guaranteed to work. Unless you’re developing software, getting an stlink and learning it isn’t worth the effort. I’d just buy a new replacement.

BTW, did you unplug everything first like Ryan mentioned? Also double checked no jumpers are placed wrong? If so, and the led doesn’t ever flash after pressing reboot… 't ain’t good.

If it is the bootloader it is not all that bad to do.

Guess who did that walkthrough…you guessed it, El Jeffe himself! I followed those instructions and flashed one myself and the hardware was,

I need to figure out how to do it on the screen now.