SKR 1.2 Pro stopped responding

It was working fine, and suddenly it get alarm of cold temperature and halted printing. I reset to re-start but it lost connection with TFT display, I try do connect using USB with computer but it do not responding. Is there anyway to test and know if board has to be replaced? I tried everything I could to restore communication but nothing. Any help will be very appreciated.



Reflash the board and screen and see what happens.

I did it and still the same, the screen keep showing the message No printer attached. and computer not recognized USB device when connect to printer. It was just working fine till it Halted with cold extrusion alarm. Is it possible that this board went bad because of the alarm?

The firmware has the thermistors disabled. I can;t see how even a bad board could cause that. It seems extremely likely the firmware is wrong. Exactly what firmware is on it?

1 Like

I Use the same firmware it was working before. I replace the board with 1.4 turbo , still not connecting with display, I replace display and still the same saying no printer attached. So not board, not display, not cable. I am lost in what could be. any suggestion i should follow to solve this? thanks

The board connects in two different ways. The grey ribbon cables (marlin mode), and the black cable (touchscreen mode).

Does either side work? Best to stick with the SKR PRo as I have zero experience with the other board you mentioned.