Setting of stepper current on Marlin

I am a bit worried about the need for updating my config adv file for the stepper current. I am a bit unsure what line number I need to adjust for this.

My steppers are Nema 17 Stepper Motor Hi-torque 320mN.m 45oz 4-Lead 2 Phase 1.5A 1.8°

My power supply is 24v 15A

The stepper motors do get a little bit warm when I was testing moving axis using Repetier and the LCD control board.

PS, am trying to use the forum rather than FB group.

Well warm is just about right. Too hot and they can soften the PLA mounts but even that would be just within standard operating specs for the most part. The more important part is the heat coming off the drivers themselves, I think they are set as high as they can go without cooling on them.

Just in case you want to have a look, here is the math.

I am thinking they are more between warm and hot. I can get my thermometer on them to check if that helps?

The heat is coming direct from the stepper motors themselves.

No heat coming from the Mini Rambo board.

You mentioned that I should setup for my voltage of the power supply as you have your defaults set to 12v. Where can I see that please. I tried to search all files for 12v.

Just bump them down from 950 to 900 and try that. It should be the same except a 24v supply is supposed to be more efficient, so you might be able to set them a bit lower than the equation linked above says.

Hi Ryan

I have got back to working on the machine again this week as I was busy on other otojects.


I have replaced to a new stepper motor, adjusted current as per your advice. However I have this time pulled the stepper motor off the Z axis assembly to see what is going on. I can screw my threaded rod with finger tips with not one bit of binding. It actually spins more easy than I expected which is good.

However, I have now discovered that the motor shaft was not spinning in the pinaple like suggested. I ordered a new spider coupling and it did exactly the same noise of skipping steps.

So I pulled motor off and held shaft with some pliers and it is pretty easy to hold the shaft from turning. This is a brand new motor. I then tested with another new motor and did the exact thing. Same noise we previously heard.

I cannot hold the X or Y motors from spinning like I can for the Z. Is there anything you may suggest? My motor is 1.5a nema17 as displayed in the attached photo. I added a video of what I am seeing now on Z.



The voltage on this steppers shudl be bigger then 3,3v???

1 Like

Ok that normal on my steppers I have 2,8V sry. Maby this one is some fancy motors and you need to do some math to se how to adjust stepstick. Check wires, check fase on motors. Now I watch your movie start with math and setup your stepstick it’s look like you need to have slightly more then 0,7 put motor in x or y and check if it’s the same if not check stepstick maby is broken.

I’m guess from the other thread you have fixed this?

Hi guys.

Issue is still there. From the other thread I have solved to get a z working. When I say working, I mean getting the motor turning.

Are these motors rated too high for this board? I should not be able to hold the stepper motor to skips steps so easily surely?

Ryan do you have a mini Rambo board setup on one of these MPCNC machines for Z axis? It seems they are not performing on Z as well as I hope.

I don’t know what number in marlin I need to change to to give more power to the Z.

I am now thinking this stepper motor requires more power than the board can produce?

What steppers and what are the specs, I doubt it though?


By hand, no.


3, and a lowRider CNC, I don’t use ramps anymore.

The ultimachine boards are capable of higher powered steppers that the drv8825 ramps add ons, do to better heat dissipation.


Motor specs? How to set them at the end of this page,SKR Pro1.2, 5x 2209 drivers, TFT35 E3 V3 -flashed- – V1 Engineering Inc



The stepper driver is built into the mini Rambo. And I can hold the motor with a pliers without much force to skip steps. If I hold the pinaple coupling or spider coupling by hand it skips steps as well.


My stepper motor on Z is 1.5a and 3.3v as per attached photo.

I hold it eith pliers because my fingers are too big to hold tgat tiny motor shaft. If I video the motor with the voupling on then you tell me I have the wrong coupling. If I tighten the coupling more it makes no difference. I am merely telling you that there is no motor spinning in that coupling. The issue from day one is that the stepper motors are not being powered enough on the Z. This is what I assumed tight in the beginning.

I am just demonstrating now that the issue was not the coupling, the issue is the power feeding that z motor. I waited 6 weeks to get the spider coupling tho test that the machine will work only to find it had same issue of z stepper motor skipping steps.


Is it at all possible that I am unlucky to actually have a faulty board? So far I have had to remap the pins so that I can use my Z axis by using the E port, and still to find that it still does the same thing by missing steps very easy.

I will be happy to send this board back to you at my expense of shipping since this has been an issue on my Z from day one.


Hi Ryan,

I Just sent you contact request to get this board back to you. Hopefully the site sent you the message. If not I have the message saved to email you instead.


It sounds to me like your stepper or wiring is bad. You tried it on 3 different ports with the same results. Swap that stepper only with a know working one wired directly.


I replied to your messages if you want to send it back.

If your X and Y are working properly, connect your Z motor to one of those (X or Y pins). If this fixes your problem, it may be a faulty driver running your Z or (if it’s adjustable) it may need adjusting. If swapping pins doesn’t fix the issue then most probably the stepper

I’m thinking that stepper has a wire broken, so only one pair is working.

In the videos I posted you can see in have done pretty extensive testing. I have tested the stepper motor on X and Y ports and the stepper motor works perfect on these.

Z has been the issue on this mini Rambo with built in drivers from the first day.