Seeking advice: possible bad stepper / possible bad driver?

My Y1 has issues.

The stepper and driver are from V1 LowRider kit: NEMA 17 and TMC 2209.

It started as a random, seldom happening thing that instead of moving as intended, it would make a weird grinding sound and either not move at all, or move in the opposite direction a little bit, or in the right direction a little bit. A reboot would usually make it go away. All would work fine.

Now it’s gotten worse, and it does not go away after reboot, and is the same problem every time I try to move or home.

Is this possibly a stepper motor gone bad? Or a driver gone bad?

Usually, the grinding sound is the stepper motor losing steps. This is not destructive. The fact that the goes away with a reboot is strange. Start by swapping the wiring at the control board between Y2 and Y1 and running the test. You can also leave the wiring alone and swap the stepper driver in the board and run the test. If the issue is repeatable, between these two tests, you should be able to determine if the issue is the driver, the wiring, or something else.

It is highly unlikely to be the stepper motor. Internally they are very simple, and in all the forum questions, I’ve only seen one bad stepper motor. Mechanical binding can also be a cause for lost steps and has been the root issue of similar problems to yours in the LR2, though I wouldn’t think a mechanical issue would go away with a reboot.

1 Like


Thank you so much. Before reading your reply, I remembered I had a spare TMC2209 driver, and I swapped it in for the one on the Y1 spot. The problem persisted. I then deliberately switched the wiring on that line to reverse. 1mm steps in wrong direction seemed to go ok. I should have tried 10mm, but did not think of it. I swapped the wiring back to correct direction, and it still has the problem.

Re. possible mechanical binding — Whenever I turn the control box off (steppers released) I have easy, smooth movement, so I don’t think there is mechanical binding.

I am now about to do your great suggestion of swapping the Y1 and Y2 wires.


OK, just switched the Y1 and Y2 wires with each other. Problem persisted on the Y1 side. So, that seems to clearly rule out wiring and driver. That seems to leave a stepper issue: either stepper gone bad, or some weird manifestation of grub screw related issue? I would hardly imagine it could be that on a fresh install on LR3 in which I used thread locker and tried to be careful on tightening the grub screws.

You can also try sending M122 after you have experienced the skipped steps. It sometimes indicates a wiring problem (ola, means “open loop on a”, stg means short to ground). It also shows you the motor current. Some firmwares can reduce the current if the driver gets too hot. (Ot prewarn is over temperature pre warn).

M122 has helped me a few times, but I am not sure it has ever helped when I suggest it. So YMMV.

Pretty much the only way a stepper breaks is in the wiring. Or the grub screws, but that doesn’t usually have the grinding noise.

1 Like


OK. Will check M122

Also, I just removed the belts entirely, and the Y1 stepper motor still makes the grinding sound when there is no belt. I think I have a stepper gone bad.

M122 all seems OK. Here is a photo:

It prints a ton more info that that. You can’t see it all on the screen.

1 Like

Here is a. Example:

1 Like

I have some spare stepper motors that are about a quarter inch shorter than the ones that came in my V1 kit. See photo. I know that mixing different sizes on the two Y’s would be ill-advised, and I gather that a smaller motor means that it ultimately has less torque. However if they are close and would work for a while then it’s the fastest way for me to get operational again. I guess I need to be in the market for purchasing some more steppers that match the ones from the V1 kit.

Thanks. I don’t know enough to interpret all that data. LOL

Looks like the V1 stepper is

… While the TwoTrees (BIQU) stepper is

Is it foolhardy for me to try to run those smaller steppers? If so, I’ll just order more of the right thing and not waste time trying the wrong thing.

Hace tiempo tuve un problema similar con uno de los motores de mi MPCNC, retire la tapa trasera del motor y descubrí que había problemas en la conductividad de uno de los cables hacia la pequeña placa que distribuye la energía hacia las bobinas del motor, lo solucione retirando y colocando nueva soldadura.

1 Like

Quote @MartinArael
Translation via Google Translate:

Some time ago I had a similar problem with one of the motors of my MPCNC, I removed the rear cover of the motor and discovered that there were problems in the conductivity of one of the cables towards the small plate that distributes the energy to the coils of the motor, I solved it removing and placing new solder.

Thanks. At this point I guess I have nothing to lose in taking a look.

Weak wiring connexion on the board can be a cause.
Do you use dupont connectors on JST socket ? If so it is recommend to remove the JST plastic holder on your board to ensure dupont can go all the way down and assure strong connexions. If ok then secure them with hot glue.

I had had same issue and i have made choice to crimp them all with male JST. I prefered not removing jst holder as i already had jst stuff and the adapted pliers.
No more issue then, but the first solution is quite a common way to do for SKR board as you could read on that forum.

1 Like

I have Dupont connectors on straight pins with no JST base. The connection there feels quite solid and secure. And, as I mentioned, the problem persisted at the motor despite switching wiring with other that had no issue. I tend to think the motor itself is the issue. Will likely try some more process of elimination steps, but that’s my current thinking.

I wouldn’t use the smaller steppers, but you can use one to test. If it still does the grindy thing with the new stepper, it’s a connection issue. The fact that it does the grindy noise makes me think it’s a wiring issue. 99.99999% of the time the grindy noise is one of the wires either came loose in the connector and gets pushed mostly out by the pin going into the connector, or a broken wire at the pin that’s making intermittant contact.

1 Like


OK, by more “process of elimination” steps, I have found that it was wiring, and specifically, the “extension” wiring connected onto the motor’s lead wires. I took the motor out, took its lead wires off the extension wires, and plugged it straight into the board, and the motor is fine. Something somewhere in the extension wires is a bad connection. This is easily solvable. Thank you all for the tremendous help. I appreciate it so much.


You are correct.

1 Like

Wires. Can’t live with them, can’t live without them. LOL

1 Like