SD Card Problems

So, I finished my build probably back in August. I made a test successful test cut using gcode I downloaded through (I think) Repetier. I played around with it some, but I ended up having some communication issues. I tried using the SD card instead, but I could never get it to read the card. It would say “Card Inserted” on the main display when the card is inserted, but in the menu it would say “No SD Card” and on that menu, it would list a single “…” entry. The card is 2GB. It is formatted FAT according to the properties window in Windows. The filenames have been changed from .gcode to .gco. I’ve tried re-seating the card many many times. I’m still not sure why it won’t read the card. All equipment is the original ordered from I have not tried to re-flash the firmware.

So, the build sat for a long time and got ignored for other things. I just got back into it a few weeks ago. I have switched laptops since having USB communication issues. I did discover that on the old laptop I had Bluetooth enabled and somehow the COM port assigned to MPCNC was the same as a COM port assigned to through Bluetooth. When I disabled Bluetooth, the communications issues went away. I don’t know how Windows can assign the same port to two devices.

But, the SD card still does not work. I have tried other cards, but it seemed this one has the best chance due to it’s small size.

I had the same trouble you describe with the micro sd cards inserted into the adapters that look like regular sd cards. I tried a regular full sized 8gb sd card and have had no trouble.
The micro-adapter setup was also giving me trouble on my windows 10 pc after one of the updates that microsoft pushed on me. This same adapter/micro sd works fine in my HP printer and the micro works fine by itself in my phone. There appears to be an issue when using adapters.

I also had an issue reading the sd card after I made extended ribbon cables to go between the controller and the LCD. One had shorted. That was resolved with fixing the cable.
Hope something here helps.

I was using a micro card this time. I swapped it out with a 512MB full size card from a friend. Still no love. I even tried formatting the card as FAT16 and FAT32. I also went into Linux and wiped the card and created a FAT32 filesystem on MSDOS partition type. (I found that tidbit on some 3d printer forum) I also tried pulling the display out of the printed case in case the wires were not seated well. (actually, I cannot use it with the case installed anyway because the thickness of the case prevents the button from pressing. I am sure I could adjust that though.) I also tried booting the printer with the card already installed.

If you have a card that does work, what does the menu say instead of “No SD Card”? Does it change based on whether there are valid files on the card?

Did you get the screen from me? It sounds defective.

Yes, all my electronics are from you.

You can ship the screen back if is truly faulty I will send back a new one and reimburse your shipping if you are in the US and use priority mail.

I tried a few more things with no luck.

I swapped the ribbon cables in case one was bad the problem might move to something else…no change

I finally checked the log in Repetier. It says “SD init fail” whenever I insert the card. But I also noticed I was on version RC6. RC7 came out a week after I placed my order for the bundle.

I flashed with RC7. No change.

I tried yet another SD card.

It’s dead Jim.

I’ll contact off the forum.

Ok. I got a replacement display and it works for three out of four SD cards. All are FAT32.

PNY Professional 16GB class 10. Good
Ultra 512MB. Good
Sandisk 2GB micro w/adapter. Good
Samsung Ultra 8GB Class 10. No good. I even put it on Linux and wrote zeroes to it to wipe it and then used SDFormatter to write a new filesystem. At least I can put an image back on it for my Raspberry Pi Zero to play emulated games.

I just got the Rambo 1.4 from Ultimachine and the FULL GRAPHIC SMART CONTROLLER LCD from V1, loaded it with V1CNC_Rambo - - 508. At first the LCD beeped and flashed so I reversed the cables at the Rambo and that fixed that. Now, I’m getting “SD Init Fail” whenever I insert an sd card. I’ve tried re-formatting the card to FAT32. My computer sees it just fine and can write files to it, but the Rambo just gives me that error. I’ve only tried the one card because that’s all I have handy. What could the problem be? The card, the LCD, the Rambo, the firmware? Any ideas?

It was the SD card. Bought a new PNY and it worked fine.