SD Card Getting Absent Minded?

Twice recently, I’ve put the SD card which appeared to load gcode normally from Estlcam into the LCD and got the ‘No Media’ message, back into the USB port it goes and I get the ‘You Must Reformat the Disc’ message. Reformat, load gcode again, into the LCD and it functions normally. I don’t have another card to try, are there other known issues I should be looking at?


I had several times when the micro SD card for my 3D printer couldn’t get read after I deleted a file. I first tried the windows format but still had problems. I understand that sometimes the Windows format program doesn’t do it correctly.

Now I use the “SD Card Association” software to format SD cards of all types.

SD association card format program

Try that.


1 Like

Thanks for the tip! As soon as I’m done with the file I successfully loaded I’ll give it a go. :+1:

Check and make sure none of the cables between the LCD and the controller are loose. I had issues with one of the cables loosening on me. I used a dab of hot glue to help hold it in place.

Thanks for that. They seem secure but I have suspicions about the USB/Card adaptor, it’s temperamental and sometimes difficult to get the LED on top to light. Next time I’m somewhere that stocks them I’m gonna get a new one. Worked fine the last few times I used it so who knows?

I’ve had this happen recently. It progressed to other symptoms such as resetting the Rambo 1.4 at random times during a run. I am running a micro SD card in an SD card adaptor. Changing to a spare adaptor corrected all these issues in my case

Thankfully I haven’t seen anything like this, yet, and the past couple of times I’ve used it it’s all functioned normally. But I will get a new adaptor next time I see one in a store.