[Reward] Dual endstops on SKR 1.3, X axis not working


First of all: i really need the machine tomorrow, and i made some HUGE changes to all the wiring so it is nearly impossible for me to return to the old situation ( 1 driver for X1/X2 and Y1/Y2 ).

Im offering €10 for the reply that fixes my issue.

What i checked before and after installing everything:

  • motor wiring is good
  • endstop wiring is good
  • the stepper drivers ( DRV8825 ) all work as expected

So today I took the time to upgrade my machine with the dual endstop feature.
I used this board for about a year now, and it always worked perfectly with 2 motors on the X and Y axis.

After upgrading, I have:

  • 5 DRV8825 modules connected to my SKR 1.3 board, 2 for X, 2 for Y, and 1 for Z.
  • 4 endstops connected ( X1 - X min, X2, X max, Y1 - Y min, Y2 - Y max ).

I downloaded the dual endstop firmware for the SKR pro, and edited the board name to the SKR 1.3 definition.
I upgraded the firmware on the board, fired the machine up: and it works! sort of…

The Y axis move ( perfectly ) and the homing sequence finishes successfully. No more skewed results on this mill!

The X axis on the other hand, does nothing. Neither one of the 2 motors move, whatever I do.
The motors also don’t ‘arm’ themselves, so I can just move them around by hand.

What I already tried:

  • Swapping the motors around, still only the Y axis moves.
  • Swapping driver boards around, still only the Y axis moves.
  • Running an M119 > endstops work, and react to being clicked by hand.

It seems like the Y1 and Y2 are not outputting any commands to the drivers.

Does anyone has any idea what is going wrong here?




Just a guess, but since you just switched to dual end stops you were only using 3 drivers before? Did you check the current settings on the 2 new drivers?

1 Like

I checked the current settings, and i set them all up to 0.5 for initial testing. Its really annoying because i can swap out the driver boards & motors in any way possible and still the X axis doesn’t work :confused:

I really think there is something wrong with the firmware. I have a bunch of TMC2130’s lying around so i will try these next tomorrow morning, but even if those work: i dont want to use these for the CNC because they can deliver less torque if i recall correctly. I’ll also try the old firmware ( 3 drivers instead of 5 ) to make sure at least one of the outputs work that way.

Turn them to .7 and see I don’t have that board yet but was plaing on it for my next thing

That would lead me to suspect the wiring. Are these wired in parallel or series (i.e. dual ends top or non-dual endstop)?

1 Like

The Marlin. Builder has a configuration for dual XY on a skr 1.3 (not pro) with drv8825s:



This is new, based off of a config that has been tested, but there are 24 versions and not every one has been tested.

I would agree based on the symptom and also

Simplest thing first, unplug from the board and measure the coil resistance to check it’s not open circuit.

1 Like

Your symptom (no power to X motors it seems) could be caused by the X end stops already triggered. Are they set to Normally Closed NC or Normally Open in the config, and does the wiring match?

Remember the micro switches usually have three terminals; you can connect them two ways. Use a continuity beep test on your multimeter.

1 Like

The endstops are only read during homing by default.

Jeff is right and the motors would still be energized.

Ah i did not know that, thanks Jeff.

Easiest way to check that doesn’t even need a multimeter:
-unplug the motor
-use some kind of conductive thing to short the wires between 2 coils.
-try turning the motor shaft by hand

If it resists turning, then the coil is ok
If it turns smoothly, then either you didn’t find the correct wires combination for that coil, or the coil itself is damaged, or the wire is cut somewhere
If it is always hard to turn even if you haven’t shorted the coils, then you have a short somewhere inside the motor

Anyway, I don’t think this is the cause since he said he swapped the motors and it was fine, but never hurts to double check, especially since it takes only 2 minutes to do.

I never had the opportunity to use the auto square feature, but I think this issue is likely to come from the firmware, probably needs to activate the option or tell the board to use the two drivers for the X axis.

Just re-checked all the wiring, and everything is fine. I tested the steppers using a red led plugged into the motor connector, and it turns on when i spin the motors so the wiring is working properly.

I will try the marlinbuilder firmware now, maybe i missed some setting. I’ll let you guys know if anything changes!

Are you homing x and y separately or with one command? Does x move normally when not homing?

Allright, so i tried every suggestion, and i still had no movement on both the X outputs. Drivers were fine, motors were fine, cabling was fine…
It drove me kinda mad, so i took apart an older 3d printer to salvage the SKR 1.3 board in there. And tada… movement! Everything works great now.

Somehow the 2 X outputs broke on my board, but that’s fine. I just reconfigured everything for one of my old 3d printers that only uses 3 outputs anyway.
Thanks for the suggestions all!


That’s lucky you had another board, would have been very hard to guess this otherwise…

1 Like

Wow that’s scary. Doesn’t really matter now that you’ve solved it, but do you know if it was on the input side or output side of the stepper driver?

Also I’m trying to imagine how this can happen. Dragging the X axis really fast could generate high voltages into the stepper driver from the output side, but I would expect it to feed back into the motor power supply and fry maybe a voltage regulator and then everything is dead. If somehow the high voltage were isolated to the X axis drivers then it could fry the motor drivers and then fry the enable/step/dir pins on the controller but I am not seeing how it could be isolated to the two X drivers. Unless it is a freak coincidence that something dropped on the board and just happened to kill the two X channels. :man_shrugging:

I think it has something to do with my fuckup at first: i had the board powered on while installing the first set of cables ( X1 and X2 ).
Also, i used this board earlier in a ender 3 pro without success. I messed up and put the tmc2130 drivers the wrong way back then… which resulted in a fried driver. Maybe that messed up the outputs back then?