Repeatably Wierd - Accuracy Issue

I’ve written a python script to generate some gcode to draw a bunch of circles, diamonds, and squares for calibration purposes. One circle is entirely messed up (top right corner of cutting area), it starts in the wrong place! Check out the left side of the circle…

I’ve attached the gcode, it’s correct. I ran the same gcode multiple times and it repeated everything as exactly as I can see, including the screwed up circle. I ran some gcode commands manually, jogging to the start of the circle, entering the arc command and drawing it in the air, still screwed up. However once I was at the circle endpoint and ran the arc commands the arc followed the correct path and closed the circle.

These are supposed to be 4" x 4" circle-square-diamonds. You’ll see that each of them are slightly undersized in the x direction, and about right or just barely undersized in the y. I’m confidant all my belts have enough tension if not possibly too much.


My MPCNC has about a 570 x 310 mm cutting area. I’m running the dual endstop firmware on a RAMBo 1.4. I’m using CNCjs as my gcode sender from a rpi 3b+.

csd.gcode (4.75 KB)

My only suggestion is take some of the tech out of the equation, at this point you are testing every single thing in the chain, and random errors point to electronics not hardware.

Run the gcode from repetier host or form the LCD with SD.

You are asking a lot of your Z axis at 30mm/s, and drawing at 35mm/s could have a speed/accel wobble, check your 90 degree corners for wonky stuff.

If you want to keep the entire chain, maybe specify what each firmware software version is.

You are chasing a random <0.5mm error That is extremely difficult for any of us to help with without having our hands on it. The random error is not good and should never happen but the half mm error could be anything.

Also make sure everything gets rebooted between each test.

[attachment file=99545]

I ran the same drawing all day everyday at MRRF, Barry would run one on top of the previous one, with a 0.3mm pen you could not see a single deviation on a 20minute drawing.


I have attached a 40mm/s and 100mm/s proven file. (329 KB)

1 Like

Thanks for the super quick feedback. I didn’t even think about how hard i was pushing it. I slowed it down to cutting speeds (8mm/s xy & 3mm/s z) and am rerunning the test in repetier now. I already see a problem… stay tuned, this thing is still runnin.

I’ll run your file next.

Btw, the messed up circle from the previous test was 2mm out.

After turning down the speed on my first file I’m getting the same results. This time using repetier-host 2.1.3 on my win10 laptop. Latest dual endstop firmware as of 4/29/19

I did notice that to a very small degree it does starts the circle too far to the left in the bottom left circle as well, it might be out 0.5mm. The rest of the shapes end exactly where they started as they should.

On the positive side, I ran the code twice and both times the pen followed the same paths exactly! … including the error. Repeatably weird.


Try the five drawings in a different order. If you have backlash in the X axis, the circle in group 3 comes after a left-to-right movement, but all of the others come after a move either right-to-left vertically, and wouldn’t show X backlash if it were present (because the circle finishes right-to-left).

You could also try drawing rectangle first, then circle, then center point, and see if it’s the rectangle that shows the defect instead of the circle.

(I say “backlash” but it’s probably a more complex interaction of friction and stiffness, not really backlash in the usual sense of a loose lead screw.)

1 Like

6 hours later and I’ve found the issue. An x motor’s pulley was loose. I’m now drawing 5 nearly perfect ‘circle-square-diamonds’.


Each individual csd is as square and symmetrical as I can measure, as well as the whole drawing. The only issue, if I can call it that, is the y axis is short 0.5mm over 188mm. The x axis is dead on over 450mm. I’ll see if I can figure that one out later… it’s late.

1 Like

I don’t think I’ve had a loose pulley yet, but the day it happens they’re getting superglued in place!

Haha! I did reach for my loctite but decided against it this time… Mainly because it was way past my bed time. I checked the three other pulleys and none of the other set screws had worked them selves loose. Had to have been assembler error.

But it was Jamie’s suggestion of backlash that inspired me to even start checking there. Thank you again. I’ll have to modify my calibration script to draw the shapes in such a way to exaggerate that issue if it’s there.

Dammit, how did we not say that first, that is Always the problem. New shirt needs to be made, instead of “have you unplugged it and plugged it back in?”…“Have you checked your pulley’s?”


Sorry we didn’t go there first.

one of my pulleys was lose too, i noticed it because i tried to move the axis while powered on to verify both motors are good… i checked the wires, swapped the connections and everything before i noticed the thing spinning freely. you should really write that in bold red in the instructions for idiots like us.

I have done it on every machine I have ever built.I think it is always one of the last things to do so the excitement makes me extra scatter brained.

Hey Ryan. The assembly instructions for the prusa 3D printers had a good tip for making sure the pulley and belt were not loose.

They said to manually move the tool, carriage, assembly (whatever) all the way to one side and hold it there with one hand. Then use pliers to grip the motor axel and try turning it either direction a little. That should reveal loose belts or pulleys.

When I assembled my first 3D printer, the instructions said to use Loctite on the grub screw. They were very emphatic: no, really, use Loctite on the grub screw! In my hubris I thought, nah, I’ll just snug it down real good.

Wouldn’t you know, after a dozen hours or so of printing, the screw came loose, ruined the print, and sent me for several hours looking for the problem. I felt so dumb, but I sure learned my lesson.

Lol, well apparently the collet nut needs some loctite too :wink:

I’m starting to notice a pattern…

1 Like

Your calibrated wrench hand needs calibrated!