Rapid Movement - Firmware vs. Gcode

I know rapid movement has been discussed in a few other topics but I did not find this specific question and did not want to revive 1+ year old threads.

I understand the rapid movement is firmware limited (120 mm/s for X and Y and 30 mm/s for Z). I can also confirm these numbers on the LCD screen under Configuration. However, when running a project, the rapid movement appears slower than my project feedrates (e.g., moves during cuts much faster than when it moves from one cut to the other).

Typically I run my projects between 12mm/s and 18mm/s for X and Y; however, when I look at the GCode (generated using FreeCAD or VCarve depending on project), the feedrates in the GCode are in mm/min (e.g., 720mm/min vs 12 mm/s).

My question is: Is it possible that, because the GCode is in mm/min, the default_max_feedrate in the firmware is being interpreted as 120 mm/min instead of 120 mm/s?

Thanks, Victor

It’s unlikely that mm/s vs mm/min are being misinterpreted in the Marlin feedrate limits. And 120 mm/min would be very slow indeed.

Marlin does not understand the distinction between G0 and G1, meaning it has no concept of ‘rapids’ per se, and if the feedrate is unspecified for G0 then it will use the previous specified feedrate whether it was specified on G0 or G1.

In your case the most likely culprit is probably CAM inserting slow feedrates. Double check the gcode to see if you have slow feedrates in the gcode and if so then dig into the CAM settings to fix it.

1 Like

Just piling on here. If you have this:

G1 X10 F720
G0 X100

The G0 will move at F720, or 12mm/s. There is a setting in Configuration to use rapid speeds, separate from G1 speeds. But it isn’t enabled by default.

Thank you for the quick replies. Jamie, I did not know that Marlin did not distinguish between G0 and G1. The Gcode only has speeds specified for G1 so the first movement is very slow until it starts cutting.

Jeff, I just checked my configuration settings (via LCD) and could not find anything to enable rapids. Can this be enabled in the firmware?

1 Like

I found some options in the firmware Configuration_adv.h:

This is probably what you are looking for. I would think these are still limited by the max feedrates so you are safe and won’t exceed the Z speed limit for example.

1 Like

Thanks. I enabled G0_FEEDRATE at default 3000 mm/m (i.e., 50mm/s) but left VARIABLE_G0_FEEDRATE commented out, no need for GCode to set it. I’ll test tomorrow.

1 Like

This did the trick, G0 is now recognized and the machine hums along nicely!