Random Z Issue

My Z axis will randomly stop working on longer programs. I’m routing 1/4" plywood with a 1/4" end mill.

The machine will stop plunging part way through the program. It happens at a different place every time, but it always happens. One time I ended up with an onion skin, but the other times I’ve gotten only about halfway through the program. After that the program keeps running but it never moves any lower in z space. Shorter programs have run without any problem.

Any ideas what might be going on?

I attached my gcode in case that helps.

CNC_Test_BoxSide_012017.txt (298 KB)

Do you have a fan blowing on your stepper drivers?

Yes, I have a 40mm fan blowing directly on them constantly.

Are you trying to use RC8?

Flash the Rc7 firmware.

I’m running RC7, I reflashed earlier just to be sure, but it didn’t fix the problem.

can you answer the sticky questions to try and narrow this down a bit.

nevermind, you are using the old version of estlcam, you need to update. It doesn;t have z speeds.

Okay, which version should I be using? I’m running 9.018, everything else says it is a Beta.

I would use the newest one, “beta” is being used very loosely now a days.

Okay, I will give that a shot. Thanks!

Okay, that helped but it’s not 100% yet.

This time it worked properly until it had to do a z movement for the first holding tab. It lifted for the tab, but it didn’t plunge all the way back down, then it proceeded as if Z0 was higher up than I set it. When it lifted for the subsequent holding tabs, it lifted a couple mm higher than necessary and then plunged about half a mm into the material, instead of plunging 2.5mm like it was supposed to.

It seemed like it skipped steps, but there was no noise or anything like I’ve seen with skipped steps in the past.

  1. Did you buy everything from here?
    No, I had most of it already.

a)If you didn’t or changed some things please don’t leave out any details and include what firmware you flashed.
I flashed the RC7 firmware from the vicious1 website onto an official Arduino CC Mega 2560 with a Sainsmart Ramps 1.4 board and Pololu DRV8825 drivers (I’ve already tried swapping the Z driver for a spare).

My Z stepper motor is an Aleph Objects/Lulzbot Nema 17 with the following specs:
Step angle: 1.8°
Holding torque: 55 N.cm
Rated voltage: 2.8V
2 phase
Resistance per phase: 2.8,±10%
Inductance per phase: 4.8,±20%
Operation temp range: -20°C ~ +50°C

  1. Are you using end stops?

a)If so please disconnect them.

  1. Mac or PC?

CNC_Test_BoxSide_012017_02.txt (18 KB)

What z speeds did you use?

Did you see the setup here, https://www.v1engineering.com/estlcam-basics/. There is a new picture with the settings.

Yes, I followed those settings. I just double checked them. I hadn’t set the rapid feed settings on the coordinates page. Could that be the problem?

Here is a screenshot of my settings: https://www.amazon.com/photos/share/dEBzyW6zmcUBMcXLQlDi5Ho1eaisUzU0SXnU2c9QWvp

Yes, You have to set the rapid, that is the update.

I’m still having the same issue. I noticed this time that if I manually turn the Z axis while the program is running, it turns freely.

Could this be a hardware issue? If so, should I swap out the stepper or the Ramps board first? I’ve already tried multiple drivers.

What amp rating are your steppers, what have you set your drivers to, have you tried plugging a different stepper into you z port? My wires or your own?

It sounds like you need to do a lot of trouble shooting. It could be somewhere in your ramps stack (arduino, ramps, driver), your wires, your stepper, or your gcode. At this point you have ruled nothing out.

swapping drivers only eliminates a driver issue.

physically swap steppers, but leave the rest the same.

use repetier manual controls for all testing.

Z Axis Stepper - rated current: 1.5A
Driver voltage: 0.7V (just measured)

X and Y Axis Steppers rated current: 1.2A
Driver voltage: 1.38V

Pololu DRV8825 drivers for all three axes

I am using your wiring on the Z axis, but not the other two axes. I had made my own wiring harnesses before your wiring arrived but I made the Z axis harness too short, so I used your wiring on that axis.

I haven’t tried using a different stepper on that axis yet, but I will do that and report back. However, I don’t have issues with manual control until directly after a failed program, in which case nothing happens when I try to manually move the axis with Repetier/Pronterface.

Your x and y driers are fine? With very active cooling I have never been able to push a driver higher than 1.1V

If manual control works (no control after a crash is a normal safety feature), the problem is gcode related. Are you using the new estlcam beta setup correctly with the separate z and xy speeds?

Weird. No I haven’t had any X or Y issues at all. They work perfectly.

Maybe I’m not measuring properly? I have the stepper attached but not moving. I’m measuring with the positive lead of the meter on the driver potentiometer and the negative lead on the negative terminal block of the Ramps board. Is that the correct way to measure?

Yup, that’s how I do it. Then I do a manual movement to energize them and test again, some drivers change values. Whatever, if it works it works. Make sure your steppers are not getting too hot and you should be fine. Wired in series at .7V my steppers get warm enough not to want to turn them up much higher.