Random z-axis plunge using Vectric vCarve

I ran the test model that Vectric offers in their trial. I did a profile toolpath and it worked fine. However, during a pocketing toolpath about 10min in the bit suddenly plunged deep into the wood. I’m not sure it ever would have stopped until the z-axis bottom’d out. I had to cut the power. Definitely my first experience with “what’s the smell? Oh, that’s wood burning” My first thinking was the comms between my laptop and MPCNC studdered and the MPCNC somehow got stuck doing a negative Z-axis waiting for the next command. But that’s not really how GCODE works since you give it a destination. I also looked at the toolpath generation in Vectric and there’s no Z-axis move located anywhere near that spot. I can’t say for sure, but looks like it was right where it changes from an X-axis moment to an X+Y. This was the second pass. The first pass went fine.

I’m still a noob. I’ve done some limited CNC work via Fusion and never had any issues. This is my first cut using Vectric.

I’m going to try the test cut again, but thought I’d ask if anyone had an idea before I did it.

Did you check to make sure the bit didn’t pull out of the collet? I had a similar issue on one of my first projects and it turned out that I had not tightened it enough.

Just checked and the bit is still nice and tight.

From my reading on the forum, the closest similar problem I’ve seen was caused by electrical noise scrambling the g-code commands. Though not as close a match, you might 1) check the grub screws on the coupler on the Z axis, and 2) check that the Z feedrate is both limited appropriately in the firmware, and has reasonable values in Z movements in your g-code file.

1 Like

#1 - Grub screws still nice and tight
#2 - I’m running the V1 official releases
#2b - I spot-checked some of the moves with Z and it was 381 which seems very conservative. Also, at that moment, the toolpath wasn’t supposed to do any Z movements.

Here are a couple online viewers that you can use to double check that your gcode is not the issue.