Random movement while moving, ? electrical noise



MPCNC purchased from here, RAMPS board, separately sourced LCD screen, gcode generated in ESTCAM. Worked perfectly with SD card in screen for over a year. Now while trying to cut ot some 0.8mm thick aluminium using a single flute carbide tool with a trochoidal cut the MPCNC randomly moves in either X or Y in a straight move( not trochoidal) Sometimes its only about 10mm other times the gantry want to move to its hardware limit. I have examined the GCODE and there are no moves that would generate the effect and the simulation in ESTLCAM doesn’t have the moves which do not occur in the same place or always.

I suspect its some form of electrical interference (no fridges or other devices on the circuit which is in an external workshop). Before I retry the exercise after removing the LCD screen and using REPETIER does anybody have any other suggestions. I am beginning to run out of aluminium blanks!




Try turning ARC’s on or off.

Probably obvious in the USA but for simpletons in the UK what are ARCs?

4th picture down, arcs setting, turn it off. At a later date you can update the firmware and it could work either way.



gotcha thanks, will try that. As the RAMPS / Arduino mega firmware is the original you burned in November 2016 if I pick up the latest version from your site are there any other things I need to know about?



Nice! OG MPCNC user.


Try that setting first. Updating the firmware is a good thing but I am going to make an effort to make a bigger revision in the next few days/week (pretty soon) so maybe wait for that.


update on this issue. Estlcam V10.044 was set up with ARCs enabled. After carefully examining the gcode there were no G02 or G03 moves in the file so I reran the file that demonstrated the problem from a PC with Repetier and it ran perfectly. I then repeated the job having disconnected the LCD display with a newly created file (ARCs still enabled) uploaded to the PC hard disk and it ran perfectly. I have not yet done the true scientific test of reconnecting the LCD and running from that.



It also depends on the segment lengths. You are using an early version of Estlcam. Even in V11 we have found a few operations that were generating tiny 0.1mm lines everywhere. This chokes the buffer. Sounds like a bunch of small moves that might be just fast enough over usb and not quite fast enough from the SD. Or some other firmware things.

I am working on the firmware, last night and this evening. Updating and trying with the current software and firmware is the only thing that makes sense to me. Trouble shooting old stuff isn’t a good idea as the issue might already be resolved.


This was the first time I had used trochoidal cutting and looking at the gcode there are a lot of very small movements and after the gcode worked with no problem while reading the SD card in the laptop and using repetier I reasoned that it might be an issue with buffering which is why I ended up doing it the way I did.

Until this issue I hadn’t realised there was a version 11 of Estlcam which I discovered while trying to troubleshoot the issue and as my German isn’t up to understanding the differences I reasoned adding another variable wasn’t a good idea. I will now explore V11, do you know if there is there an English / American forum post detailing the differences?

Thanks for your input


I use a browser plugin called simple translate, or chrome has it built in I think. It will translate an entire page on the fly.