Ramps 1.6 plus X1 and X2 locked up

Hi, i’m trying to get a mpcnc with a laser head to work. I’m in a bit of a rush and have to get this done as fast as possible to start cutting for the client. i tried to set up the dual endstop firmware and almost got it to work. Right now if i connect through pronterface X1 and Y1 move as they should but X2 and Y2 just completly lock up. I have tried all the motor cable runs and everything works, if i swap the X1 and X2 cables X2 moves and X1 locks up. the weird part is that at some point Y worked as intended with the two motors moving in the same direction, but i had a broken X2 driver. i swapped them arround and changed it for a working driver and now Y has stopped working as well. With the broken driver X1 moved but X2 wasnt energized. Now both X2 and Y2 are energized, but dont move when 1 does. Also i have endstops unplugged for testing but i have inverted them in frimware, thats the only change i’ve made from stock firmware. M119 reports all enstops as open. Please help

Reading through, it is unclear want is going on. Some ideas:

  1. You didn’t really get the dual endstop firmware on the board, so the powered stepper is attempting to pull the unpowered one along. You can test this by just moving the steppers a bit and then, without turning anything off, attempt to slide each axis at each truck. All four steppers should be engaged, and you should not be able to slide the trucks. If the trucks are loose, you either have the wrong firmware, or you have a problem with the stepper driver (like the current not set correctly).
  2. You could have two stepper drivers operating in opposite directions. You can test this by unplugging the working stepper when the board is unpowered, and then seeing if the remaining stepper will move, and if so, in what direction. You can flip any one connection on the cable going to a stepper to reverse it direction.
  3. You don’t have the current set correct on the stepper drivers. Most Ramps boards use A4988 or DRV8825 drivers. Both drivers need to have the reference voltage set correctly in order to provide the right current.

If you unplugged or swapped the drivers around while the board was powered, there is a chance you’ve blown drivers.

As for the laser, to get it to work well, you want to control it using inline commands. The firmware maintained by V1 for the Ramps boards does not have laser support enabled. There are 7 lines that need to be changed in configuration_adv.h to enable laser support. Then the result will need to be compiled and the board flashed.

Okay i forgot to clarify a few things: All the stepper drivers work, i have verified them one by one, if i put them on the X1 slot they are able to move the motor with no problem. Same for the individual motors, they all move correctly if plugged either on X1 or Y1. They are also not moving in oposite directions, if i tell the machine to move in the X axis, X1 will move and X2 will completly lock up. i cannot manually turn the shaft, and it will not attempt wo move in either direction, just energized but locked. I have also verified the current on all drivers, as i said, they are all able to move the motors. they are DRV8825, i have a few TMC2208 on another printer that i can temporarly rip out to test, but i would prefer avoid doing that. i did a few more tests and found some weird things. I downloaded the firmware a few times, and for some reason one of the ones that i downloaded (wich again, the only thing that i modified from stock was invert the endstops) works, but only on Y axis. also, if i swap X and Y motors, it doesnt work anymore. it works consistently aswell, if i flash another download and then revert back to this one it works just as before. I dont know what else to do, i’ll probably just install klipper as it has given me far less problems. If anyone has any idea of what is going on, please help

Okay turns out its slot E0 on the ramps board. i dont know if its the board that is dead or if its some sort of cold extusion prevention or something, since its weird that is only on E0.

V1 has dual endstop firmware for ramps. Did you start with that? I’m not sure what changed with the 1.6 version. That firmware is at MarlinBuilder releases.

As long as you don’t home. The endstops won’t affect anything.

You need to set EXTRUDERS=0 to make it skip the E0 port.

You can also get your clients work done with serial wiring and then need with the dual endstops later. Leave the current the same and make a small serial wiring harness to get it moving. If you wire it in serial and not parallel, you don’t have to change the current setting.

With drv8825. It is very important that you set the reference voltage.

Moving your tmc2208 will probably not work. They get their settings changed via uart and your table isn’t configured to do that. Unless they are configured for standalone mode.