Ramps 1.4 problem


I try to ran the firmware (T8 LeadScrew Versions – LowRider CNC & Mostly Printed CNC) to my Ramp 1.4 and when I hit verify this happens:


Arduino: 1.8.5 (Windows 10), Placa:“Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans4.ltrans.o: In function `lcd_setFont(char) [clone .lto_priv.128]’:

cc2VeKek.ltrans4.o:(.text+0x870): undefined reference to `Print::print(char)’

cc2VeKek.ltrans4.o:(.text+0x880): undefined reference to `Print::print(char)’

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans4.ltrans.o: In function `lcd_print_and_count(char)’:

cc2VeKek.ltrans4.o:(.text+0x8b2): undefined reference to `Print::print(char)’

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans4.ltrans.o: In function `lcd_print(char)’:

cc2VeKek.ltrans4.o:(.text+0x8cc): undefined reference to `Print::print(char)’

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans4.ltrans.o:(.rodata+0x6): undefined reference to `Print::write(unsigned char const*, unsigned int)’

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans4.ltrans.o:(.rodata+0x12): undefined reference to `Print::write(unsigned char const*, unsigned int)’

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans6.ltrans.o: In function `lcd_status_screen()’:

cc2VeKek.ltrans6.o:(.text+0x442): undefined reference to `Print::print(char)’

cc2VeKek.ltrans6.o:(.text+0x9b0): undefined reference to `Print::print(char)’

cc2VeKek.ltrans6.o:(.text+0x9e4): undefined reference to `Print::print(char)’

cc2VeKek.ltrans6.o:(.text+0xa18): undefined reference to `Print::print(char)’

cc2VeKek.ltrans6.o:(.text+0xa6a): undefined reference to `Print::print(char)’

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans6.ltrans.o:cc2VeKek.ltrans6.o:(.text+0xb42): more undefined references to `Print::print(char)’ follow

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans9.ltrans.o:(.rodata+0xc): undefined reference to `Print::write(unsigned char const*, unsigned int)’

c:/program files (x86)/arduino/hardware/tools/avr/bin/…/lib/gcc/avr/4.9.2/…/…/…/…/avr/lib/avr6/crtatmega2560.o:(.init9+0x0): undefined reference to `main’

C:\Users\ANDRNO~1\AppData\Local\Temp\cc2VeKek.ltrans2.ltrans.o: In function `lcd_implementation_drawmenu_generic(bool, unsigned char, char const*, char, char) [clone .isra.18] [clone .lto_priv.122]’:

cc2VeKek.ltrans2.o:(.text+0xe0a): undefined reference to `Print::print(char)’

cc2VeKek.ltrans2.o:(.text+0xe34): undefined reference to `Print::print(char)’

collect2.exe: error: ld returned 1 exit status

exit status 1
Erro ao compilar para a placa Arduino/Genuino Mega or Mega 2560.


I´m not very good with programing … any help??



Try the latest version of the arduino ide.

That´s the one I have

What file are you trying to flash? Marlin 1 or Marlin 2? If 2 did you see the notes on how to flash it on the firmware page?

I don’t have the compile issue on the ramps, but I recently upgraded to the t-8 leadscrew and the z-axis is way off, moves maybe 40mm when I try to move 10mm. I have tried to update the settings on the configuration.h in the arduino app, but nothing seems to affect it, it always moves the same amount. I tried downloading both the heated bed enabled and non-enabled images and both act in exactly the same way. I’ve updated the firmware to the native Estlcam firmware and that works, and then tried to update back to the firmware on the software page and it does back to the extremely high movements/mm.

Any thoughts?

Instead of updating config.h try just using my firmware that is prebuilt for the T8.

Sorry for the confusion Ryan, that is what I did. I downloaded the files from your firmware page and only when the movement was wrong did I start poking around. I tried to poke around and adjust the settings and it doesn’t seem to affect the movement at all. X and Y work great, but Z stays at the large moves. I’ve deleted and re-downloaded your firmware files and tried to re-install and it doesn’t change the movement. I changed the name in the config to make sure that the upload was taking and on the LCD screen I can see the alterations, but still no change to z movement. I bought the leadscrew from your store, so I know it’s not an issue with the wrong pitch.

I’m fairly new to this and so getting in and messing with the code is something I’d rather not do, trust me. Anyway I fidgeted a little trying to fix it and nothing seemed to make a difference so any help you can offer would be appreciated.


Do you have all three jumpers under the z driver? On the LCD what does it say for steps/mm for X Y and Z?

Sorry for the late reply, I was out of town for work and just got home. I just did another upload of the MPCNC813_GLCD_EB_T8.ino and checked the things above. I do indeed have the 3 jumpers installed under the z drive, I assumed I did as I bought the board from you and haven’t touched it. I found the steps/z in and they are set to 4,535.44, got a feeling that’s the issue right there, don’t you? I’m not sure how I’m getting that problem with I just uploaded a “fresh” image.

Ok, So I think I’ve fixed it, but I’m not sure why I had to do this. I uploaded a completely empty sketch, and then reloaded your T8 firmware, and it retained the z steps from before the empty sketch. I navigated to “restore failsafe” and tried that, and once done, the zsteps showed up at 800. I hit the hardware reset button after that and presto chango, it works fine. Z movement is perfect.

Any thoughts on what the hell is going on? I’m more concerned with short cutting this if it happens again, or completely avoiding it in the future.


Hi guys .

Sorry Ryan I sotp replay because I did not add the time to continue, but today I finally did it.

I finally got it to put the firmeware to the arduino with out any errors but, when I connected to power the lcd was showing everything withe.


Any idea?


That is a different LCD than the one I sell and pre-make the firmware for, you need to edit the firmware to make that work.

Matt it sounds like something was going wonky with the eeprom. I have heard of this before, sorry for not thinking of it.