Ramps 1.4 G code or board issue?

Heres a link to a video of the issue I am having:


So basically I am able to move all 3 axis using the controller on the LCD. Everything works as it should. First I tried to run the G code through the SD port on the LCD and the machine made 3 moves then froze up with a strange sound coming out of the z-axis stepper. I have read on the forums that the micro SD adapters can cause issues so I tried 3 other SD cards, same issue. My next attempt I made a new g-code file with a different drawing, same issue. I connected to the computer and tried to run it through Repetier-Host with the result being the same 3 moves and then freezing up. Lastly, I read another post about a faulty LCD so I tried to unplug the LCD and just run from Repetier. Also no luck. I am stumped at this point. Does anyone know if it could be a control board issue?

Can you post your gcode? Just zip it first and the site will allow it as an attachment.

1 Like

did you set the z steps, the guide shows steps per second. the new estle cam is per minute.

i had the same thing it would move to the start and whine, it was just moving the z very very slowly


Ive zipped the G-code and attached in this post. Ill look into setting the z steps as well.

TEST-CNC-BRACKET11.zip (4.09 KB)

Yea, it’s moving, just too slow to see. You have your feeds way too slow.


See if this moves your machine in the air, don’t cut with this, I don’t know if it is too fast for your machine or not. Just zero the z with an inch or so of space below it, and run the program.

TEST-CNC-BRACKET11edited.zip (4.13 KB)