Rambo v1.4 E1/Y2

I hooked up my MPCNC machine to Repetier host. I am running a Rambo v1.4 with Marlin. I was just testing it out to make sure everything runs smoothly when I noticed my E1/Y2 was not moving. Just to confirm it wasn’t a bad motor or wire I plugged that one into the Y port and it worked just fine. I also tried swapping the two around and no matter which one is plugged into the E1/Y2 port does not run. I even tried shutting everything off and turning it all back on again and still nothing. My other question is can I split the wires and wire them together so they are both plugged into Y1? If I did that I would also do the same to my X axis.

Did you flash this yourself, or did it come from Ryan? That LCD looks like non-standard equipment, so I am guessing you flashed it yourself.

Before changing any of the wiring, check that you are configured with Dual endstop firmware. The most fool-proof way to do it is to send M119 on the console. If you have dual endstops enabled, you will see X2 and Y2 endstops listed (they should be triggered). Another way is to read the printout when connected. Recent versions of Ryan’s software have a number and a letter. The number would be something like 425 and the letter would be D for dual endstop.

But, if you’re not interested in any of that, yes, you can wire two steppers in series (don’t wire them in parallel, you’ll lose a bunch of torque). They will always move in lockstep after that (so you’ll lose auto squaring).

I recognize those boards… I don’t think I had you on the dual endstop branch, did I? If you are using all 5 drivers, you’ll want to use https://github.com/Allted/Marlin/tree/V1CNC_Rambo_Dual as the starting point. I didn’t see all 5 drivers connected in your other thread.

I did flash it with this software.

How do I send an m119 on the console?

K cummins no worry about giving me the wrong software I know it was a bad picture to begin with. So I reflashed the rambo and I tried it all out. I am using the Repetier host and I noticed that the X2 and Y2 is one setting off. When I plug it into X1 and press 1 it moves about the distance the .1 moves in x2 and same for Y1 and Y2. Is there a way to speed up X2 or Y2 or should I just skip everything and wire them in series?

The code you linked (V1Cnc_Rambo) is for 3 drivers, series wiring. The one K linked is for Dual.

I don’t know how your X2 or Y2 are even working, unless they are just being dragged along by the X1 Y1.

From repetier host. There is a spot to send a custom command a place where it prints a bunch of text from the machine. I don’t remember the exact locations.

Thank you I will look into that m119 code. So I did download and reflash with the new code and all driver work just the X2 and Y2 move really really slow. I did have the same one plugged into both the X1 and the X2. When I click on just to move it 1 it seems like X1 moves 1 and X2 moves .1. does this makes sense at all?

They should move at the same speed. I can’t think of a reason in the software that would allow them to move differently on the rambo. Do you have this on an mpcnc? Are the belts on?

Maybe the pulleys are loose? Do you have the same size pulleys on both ends?

If that’s not it, can you measure how much slower? 1/2 speed? 4/5 speed?

If you are sure they are moving under power, then you don’t need M119. BTW, it is case sensitive, so you do have to capitalize the M.

I am now wiring them together and I tested it out and it works just fine. So now I am about ready to soder the wires together and make them permanent. But I do thank you guys for your time. I am learning a lot from this new MPCNC maching the one week I had it.

Make sure you wire them in series. You will lose a lot of torque if you wire them in parallel.

I tested them out and they work perfect in parallel I did take our advice on that.


They do not work perfect in parallel. But if you want to wire it that way, go ahead. You will skip steps, but it’s your machine.

Sorry i meant to say series.

1 Like