RAMBo not connecting either

The RAMBo just received is exhibiting the same behavior as the RAMPs. Using the Arduino IDE on both a Raspberry Pi and PC, it won’t connect with the USB serial port at any speed. It shows garbage characters at most speeds, but at 250,000 baud, it displays “Error while setting serial port parameters: 250,000 N 8 1”. When attempting to connect, the RAMBo does blink the external LED twice, and then the on-board LED once. The same setup, same cables, will connect to an Arduino UNO. I can send it a Hello World program and have it read and write successfully at 57,600 baud.

In hoping that the RAMPs controller was not fried, or I could swap out the Arduino for a spare Mega, bought ages ago, I did not cannabalize power supply that came with the MPCNC kit. I attached the RAMBo 6 pin power connector to a Mean Well NES-350-12 12V 350 Watt Ul Switching Power Supply 110-240 Volt that I bought 1-1/2 years ago for another project. It has very good reviews. Each connector on the Mean Well was connected with 12 gauge stranded wire to the corresponding RAMBo connector. My DMM showed 12+V on each of the 3 sets of connectors. Initially, I tried to hook up the X-axis and 3 of the minimum endstops (NC). When that did not work, I removed them, leaving just the power connector and USB. It still will not connect. This is beyond frustrating. I am not sure my next debugging step should be. Is there a QA test I can run against the board? Thank you.

Why arduino, have you tried repetier? If two completely separate boards are having the same issue, it is down to something on you computer.

Do not plug in anything other than power and the USB. Do all your trouble shooting with a naked board.


Does repetier, or the arduino IDE show either board as a valid com port selection? Do you have another computer to try? It is also best to unplug everything you can from your computer, just keep keyboard and mouse. Some dongles really screw with com ports.

Success! I installed Repetier Host. It connected. I cut power and installed the X-axis wire and 2 of the 3 endstops (NC) on the Min and Max. It moved!! Thank god. This last stumbling block made me so sad.

I do not understand why Repetier would work and a terminal program would not. Is it a different USB protocol than serial? But why then specify baud rate. I am very confused.

I do have one more question as I wire up the Z-axis, etc. The RAMBo kit came with 3 wires and 3 switches for endstops, and the RAMBo board has 6 connectors for X, Y, and Z. The doc says I have to have endstops, but which do I plug them into, Min? or Max? Do I need the other 3? My previous order had 4 switches, so I now have 7. I could wire up the other 3 if I had the connectors. What is the type of 3 pin connector? Do you sell them? I did not see them in the shop. Thank you. <deep sigh> …light at the end of the tunnel.

If you are running the dual endstop firmware you need X and Y min and max plugged in NC. If not you do not need endstops.

It is the firmware that you put on the RAMBo. Is that the dual endstop firmware? A friend who designed his own CNC machine is coming over on Sunday. Hopefully he can reduce my ignorance and help me get it all working.

Hi Frederick,

I struggled a bit with the RAMBo board (documentation seems to be lagging behind the product a bit - its a pretty awesome board, but some of the info online requires a pretty high level of understanding to trawl through to find the relevant stuff) - some tips from my recent slightly painful experience…

  • Get your RAMBo drivers up to date - Ryan's pages show how to do this
  • If you are reflashing using the Arduino IDE (for example to a new version of Marlin with dual endstops), use the stable release version of the IDE, but unzip the file into something like C:\Programs\ArdunioIDE or something. i.e. with a very short path to the folder, not where it wants to normally place it like C:\windows\users\dave\dave_docs\another_directory\some_attempt_at_filing... as it errors out.
  • Unlike the smaller Ardunio boards, you need to have it connected to power as well as USB for it to upload successfully. (the lights come on with the USB plugged in, but no one is at home. This confused me for literally hours before i figured this out...)
  • Connect the power as shown in Ryan's page about the RAMBo board - i.e. you need the logic and drivers parts of the board powered up via the jumpers.
I drew a quick sketch of my wiring for the motors and the endstops (limit switches) below.

Plug it all in (with the board not powered), then play around with the motor plugs (flip them over) until the motors are turning the right way so that a home command drives the gantry towards the endstops (only unplug and flip with the board depowered). I’m sure its possible to do this in the Marlin config, but flipping plugs is way easier.

Check the limit switches are limiting the correct motors, i.e. the switch stops the motor on the same rail.

Should be good to go.


When plugging the limit switches into the board I used the three connectors that were supplied, then for the other two I used the spare two pin connectors supplied with the board, crimped the new pins onto the switch wires (fiddly little blighters), and then cut off the clips and lugs on the plug so they could be jammed into the 3 pin connector on the board. Not pretty, but effective.

Make sure you connect the switches to pins S (signal) and - (minus) only. There is a danger that you might connect another combination of pins if you do the suggested connecter mauling above…

hope this helps


1 Like

Very nice write-up!

I have been making progress, despite stepping in all the possible potholes along the way. Turns out that around 2 weeks ago, a new version of cncjs was released that addressed a problem running at 250000 baud on Raspberry Pi. Octoprint did it with a patched version of pyserial. Repetier Host probably had a similar work around build in. I was probably suffering a similar problem running the Arduino IDE. So after much trouble, cncjs is communicating with the RAMBo controller. I will go back and check the RAMPs and see if it is okay.

I don’t know why, but what I had read so far, led me to believe that the firmware Ryan put on the RAMBo board required endstops (NC) on all the axis, min and max. After discovering the M119 command, it said all my endstops had been triggered. So I removed the endstops and the jumpers, and all is well. I have yet to draw something using the pen attachment, but the X, Y, and Z axis(s) are all wired and working. Thank you all for the help.