Problem generating g code

I built the Lowrider CNC v3 using your SKR Pro 1.2 board loaded with the Marlin 2.1.1. and I have worked more hours than I like to admit trying to figure out the problem with the g code I generated in Estlcam. My lowrider will draw the crown from the supplied g code file without problems. When using the crown DFWx file in Estlcam 11.245, I can create the gcode file, but the CNC does not like the code. It seems like the z-axis bottoms out, and I have to unplug the machine before it implodes. I am attaching an image of the crown drawing and the problem gcode. I have enjoyed the build process but am over my head with the gcode language. Any help is appreciated.

Thanks and i hope the attachments are readable.


estlcam (8.3 KB)

Looking at your “gcode” file, it is not in the correct format. I suspect the issue was caused as part of you packaging up the code to post to the forum, and not the root of your issue. All the braces and the back slashes are not valid g-code. You need to take a look at the code you are running on your machine and verify that these items are not in the code. Note that “.gcode” files are one of the file types that can be directly attached to a forum post…you don’t need to put it in a ZIP. Here is a section of your g-code.

\cocoatextscaling0\cocoaplatform0{\fonttbl\f0\fswiss\fcharset0 Helvetica;}

\f0\fs24 \cf0 ;Project 0102\
;Created by Estlcam version 11 build 11.245\
;Machining time about 00:03:37 hours\
M03 S24000\
G00 X0.0000 Y0.0000 Z0.0000 F2100\
G00 Z2.0000 F400\

Now on to your problem. It is highly likely your issue is because you do not set a home position relative to your “stock” (paper in this example). Add the following line to the top of your g-code file:

G92 X0 Y0 Z0

This line will establish the router position (tip of the pen) when this line is executed as the home/origin position for the job. Your g-code moves down 1mm to start drawing, so you want your pen tip to be just off the surface of the paper when you start the job.

Establishing the origin of the job using G92 can be done automatically by adding it to the start g-code section for your Estlcam jobs. It can also be done manually through a variety of mechanisms. People do it both ways depending on their process for setting up jobs.

I didn’t understand that I needed to add anything in Estlcam jobs to the start g-code section of Estlcam. I now understand and have it working. Thanks for your help.