Probe "touch status"=ON, (FluidNC - MPC&C - Jackpot)

This is the probe test image in FluidNC.s aways on triggered (green button-ON). Tested gpio36 and showed low to high response on the Jackpot board ( led test - On and Off when manually closed or open - (OK…)) does not respond to M119 command - no short at terminal or this be a config setting problem or should I look elsewhere?
can’t use probe - error ! Version 3.7.18 after installing in a new ESP32 (8gb mem) from V1 with the intent of installing a pendant.
Any suggestions on what I may have done wrong? Configured with gpio pin 36 …:low.
Everything else seems to be fine.

Is it possible that resistors are needed for the gpio pin 36…if so would pull up or pull dn be needed?

see image:

Here is my LR3 config that I posted in another thread. Can you compare with yours, or upload yours and I can compare?

Also, is it working apart from this? Is it a new install, or have you just upgraded to 3.7.18? 3.7.16 is the recommended version.

Thank you for the quick response!
I purchased a new ESP32 in the event I would brick my original ESP23. My intentions were to attempt to try the m5 pendant UART(2) added …soo… I installed (new install) the latest ver. 3.7.18 (I now know .15 would be a better choice.) I have included “MY”. > config file for my Jackpot controller w/ end stop switches thru FluidNC :

aconfig (2.0 KB)

just as an aside I have not made any chips yet. But, all seems to be working otherwise.

How did you make that config.yaml? Its got loads of differences to both mine and the default one that Ryan has on github.
Maybe copy yours and try the default one and then edit that to have the changes you need, just see if it works as default first.
This is the one currently on github and it looks like it has had the changes needed for it to work with v3.7.18
I think you are using an MPCNC on the v2 UI.

You can have multiple config.yaml’s under different file names, but it is easier to save yours, delete from the jackpot, upload the default and power cycle the board. I think starting from a known good config is the way to go.

1 Like

Thanks again-- The config file you provided worked! Of course i needed to make some tweaks to adjust for the mm/steps and a few others. but it did allow for the probe. I also redid the connections for my stop switches which seemed to be loose, and between the 2 solutions i have found some success. I can’t recall how i arrived at the config file that i was using…nubee mistakes. learning can be a challenge but fun when thing work now I’ll to try and cut something :wink:

Regards and Cheers

one other question- z does not home at all when homing button in Fluid is selected. any ideas?

Hi Jeff If you had to change your mm/step and other settings then you must have a non standard built. Also the MPCNC doesn’t home z up without mods, but I think its enabled in the config file. The LR3 does home up and probe down in Z, so you could always look at that for reference.

I think the config is already in there - check the pin

      limit_neg_pin: NO_PIN
      limit_pos_pin: gpio.34:high
      limit_all_pin: NO_PIN
      hard_limits: false
      pulloff_mm: 4.000

You can check if it works by putting $HZ in the console. Try that first. If it works you can get it to home when you home all by changing the z homing cycle to e.g. 1

    steps_per_mm: 200.000
    max_rate_mm_per_min: 1200.000
    acceleration_mm_per_sec2: 80.000
    max_travel_mm: 300.000
    soft_limits: false
      cycle: 0

Change cycle: to 1 You should probably also co and change x to cycle 2 and y to cycle 3 - not sure what happens if two axes are in the same order position.

ref: Axes | Wiki.js

The MPCNC shouldn’t home the Z axis. One of the early configs had it enabled and when I pressed home all, the z core lifted all the way up until the lead screw came completely out.
All you want for Z is to use the probe to set your zero.

I don’t know if my build is non standard, but I set steps/mm to 40 to calibrate movement on x & y. The travel direction on Z is set to positive(:true) to home in the correct direction direction x&y are reversed (:false.) The’ home all’ works now. Probe seems to be ok now too. Soft stops also set to (:false.) Changing the cycles to 1 on Z and both X&Y set to cycle 2 ( they seem to operate in tandem - - could also be set to 2 and 3 respectively if desired I suppose.)
Nothing worse than a lead screw and assy. lifting out and spoiling your day :wink: Thanks for all the suggestions - “a journey not a destination”

1 Like