Pre Release v1pi needs testing

I made new images for v1pi. I created a hotspot and no-hotspot version. This has a newer cncjs and newer octoprint.

I will be working on testing this in my printers and my Low Rider, with the couple of different pi versions I have. If anyone is interested in taking a risk and trying this on a spare SD card, I would appreciate it.

If you do test it, I’d like to know what kind of pi you used, if you used cncjs or ocroprint, and what image you used (hotspot or not). And of course, how well it worked.


I will today. It’s on github? Thanks brother!

Great. It is. I linked to it in my post (0.17.1).

Ty. I just happened to see the post. Was drawing blood. I’ll download today and install. Can we install the marlin firmware to a 32 bit board . I know how. Just don’t want to make things harder than the need to be. Thank you.i have that mks 1.3 32 bit board from amazon thst looks like the Mks 1.4 ramps combo

I’m not sure what you’re asking. This image is for the pi. Installing Marlin is a different subject. Marlin does support 32 bit, but if you’re using a board other than the ones Ryan has configured, you’ll have to do some changes to the firmware configuration yourself.

Np ty

Jeff you know how it is. I was attempting to ask a question that didnt take much of your time to answer. Basically i have three boards. The traditional ramps. Tried and true. The MKS Base 1.4 that is kinda equivalent. And the new 32 bit 1.3 that is similiar in layout. The 32 bit board is new to me and I am still not sure if i want to use it or not. Thanks for the reply and I am downloading the pi as I type this.

1 Like

I’ll download it and give it a whirl. Anything I should be looking for? Anything specific you want to test? Will it sort out the backlash (or whatever) on my CNC :slight_smile: >

I only use the cnc.js side of things for my MPCNC to be honest, so if you;re happy with that…


If it does, I will start charging for it :smiley:

Just trying to look out for surprises. I have a way I work, and I am testing that, but there are thousands of ways to work. I’m not looking for anything too nit picky, but if you can’t get it to connect, or move the machine, I’d like to know. If it stalls halfway through a job, I’d like to know. If it works fine, but your wifi signal on your phone went down a bar, I will consider that a win.

Hey Jeff, i hope everyone is doing well. I didnt say that earlier.

The Pi loaded correctly and it all looks well. It was easy enough to extract the file (unzip) load up the image and then put in my network info. I can see the Pi on my monitor. Thanks again. I will have my endstops installed today and I should be able to start cutting very soon! Oh and I can open the programs and everything just fine. Thanks again

Cool. You tested the no-hotspot version, I assume?

UPDATE: I’m not sure what version of Marlin I had, but it was returning “ok B:25…” and when I flashed it with known good software, it was fine.

ORIGINAL: I was just doing some testing myself. My LR is configured with EXTRUDERS=0. Cnc.js is up to its old tricks again. It isn’t jogging unless I give it a kick with a G1 in the console. This even happens when I am running gcode. So that is basically unusable…

ya i just had everything hooked up. 5 motors. ramps. pi. I could not get the motors to work in pi. But I was able to get everything to work using reprap controller. Well to just state a bit more clear. I was using the no hotspot version. Ramps with endstops T16 32 steps. basic electronic setup. I have not done much with things over the past 4 months. I want my machine back up and running. I want to be able to make wing molds our of wood. I Currently have 4 feet by 2 feet of usable space on my machine. It will be a bit more when I am finished. Ill talk more about that in another forum. Thanks again Jeff.

And what type of pi is it? (3B+, 4, etc.)

I think it’s similar to this issue… I am going to look to see what exactly Marlin is producing as an ok message on my machine. It may be localized to my specific version of Marlin.

I am really good with what you all have provided. I can use the machine with the display or using the touch screen. However I am trying that fix they talk about at the end of the module as I type.
in the
M105.cpp replacing :
SERIAL_ECHOLNPGM(" T:0"); // Some hosts send M105 to test the serial connection
SERIAL_ECHOLNPGM(" T:293.0 /0.0 B:25.9 /0.0 @:0 B@:0");
I comment out the first line and added the second line. This compiled just fine with no errors.

so I still can not get anythign to move. i will change that back

What does the “ok” line say in the console? Mine is ok B:25.00 /0.00 @:0 B@:0.

I opened another issue, but I’m not sure how fast it will get solved, or which configuration option I have that is causing it.

Well, I just flashed the board again with what I thought was on there, and it is working fine. So I closed my issue.

Mike, it sounds like you’re having an issue too. I’d like to get to the bottom of it. If you have time.

  1. Does it work in octoprint?
  2. What is the ok message (like I asked in the previous post)?
  3. What firmware are you using? I assume that if you are using firmware from 4 months ago, it is about the same vintage as mine.

But, mine is working now (made a crown, yay). The kids just went down for a nap though, so I won’t be able to work on my project anymore today.

Hey jeff I know i have been commenting a lot with this today. I am pleased to have you all working on these programs. I wanted to say I can get the octoprint to function correctly. What I am saying is when I move an axis in octoprint the ramps commands the axis to move properly. I will flash the firmware once again. (the pi server) That may be the problem. I will get back with you in an hour I need to eat. Thanks for asking