"Phantom Touches" when z homing with plate

Hard to describe this, but lately every time I home z, at least one of the touches never makes it to the plate, usually the second one.

In other words, I clip on the probe, position the plate, g28 z. The tool descends, usually touches the plate, retreats, and approaches slower. On the second approach, it quits homing before touching the plate. A subsequent g0 z0 shows the home z a few mm over the material.

When homing works, my z is set properly, but these days it fails more often than not.

Anyone experience this? This is a burly build with all electronics from the store. Board is, I think, mini rambo. Fw was up to date as of last year. (Kinda took a few months off)


Sounds like electrical noise. Is the router plugged in? Is the ground side to the router and the signal to the plate?

Another thing to look at, is you may be developing a situation where your router collet is intermittently grounded (generally you should wire it assuming it is grounded… read on). If you have your probe line attached to the bit and the ground attached to the plate, an intermittent collet ground would cause this. Swapping the probe wires would fix it (bit connected to ground, and plate connected to probe line).

The only other thing I’d look into is your probe scripting… ensure that the script doesn’t have some bug in it where it hits max probing range before touching something.

Thanks for the replies! I didnt get a chance to try your suggestions yet. I homed by eye and ran the job successfully. By the time it finished I was too tired to troubleshoot. Will take a look tonight.

The router IS plugged in, but I do need to confirm which pole is attached to which lead. I haven’t messed with the wiring since I first installed the machine, and this was more a recent problem, but maybe something changed as things broke in.

Another possibility is that the pullup resistor for the signal pin is not functioning leaving the the pin floating. As the bit gets close to the touch plate, the pin gets pulled low enough to register “low” to the firmware. This can be fixed by either adding a supplemental 10K resistor between the signal pin and the 5V pin, or by reassigning the probe to a new pin on the mini rambo and enabling an internal pullup resistor (firmware change required), or by reassigning one of the other two endstop connections for Z homing (firmware change required).

I needed to supplement the pullup resistor on my MKS board. It would sometimes register as triggered if I touched the plate, especially when I was otherwise grounded myself.

My MKS board has 3 pin connectors for all endstops, so I just wired in a 220k 1/4W resistor that I had lying around in between the +5V and the signal pin on a 3 pin dupont connector. This is a little lower value than the integrated resistor, and in parallel, it lowers the resistance quite a bit, making the touch plate less sensitive, and requires a good ground connection in order to trigger. This resulted in a much more repeatable action with the touchplate.

I agree with the idea of adding pull-up strength. Cnc routers are often surrounded by static electricity, which can easily sway a low impedance pin when the field gets close to the probe. Adding pull-up will give a better path for those electrons to travel when and if they build up due to nearby static fields.

Just thought I would update this in case it helps someone in the future.

I hadnt used the Burly since posting, until today when I had some plywood to cut for work. The touch plate gave me fits again, so first I tried swapping the polarity of the plate/probe. I have only tried it once so far, but it is 1/1 on success. Planning on some more cutting this week, more for fun personal use, so I will update again if it holds. If not, I will add the pullup. Thanks!

1 Like

You can also try unplugging the router, unless you really don’t want to.

1 Like

2 for 2 since swapping wires. As long as it works I’m happy. No reason NOT to unplug, unless I don’t have to.

1 Like