Options for klipper control at RMRRF & OS?

I need to put it up today to get some more eyes on it today anyway. My Macro game is lame.

Though the reason I can’t go is a good one. :rofl:


Hell yeah it is!

Klipperscreen works perfect, kiauh even allowed to install it during my initial setup. Just need to add the update lines to mooraker.

Turns out when I am home it is able to run any other printer on the network…that seems wild to me. Plugged into one, wirelessly run the others.

Problem solved, thanks everyone.

1 Like

Okay, so, Either I load up a bunch of files and stick with them, or figure out how to simlink a thumbdrive. I think last time we just printed a couple Primo Cores, at RMRRF, but at MRRF we printed all sorts of random stuff. Random stuff was fun.

I have a few pages open to figure out simlinks, I need fresh coffee for that. seems a little more complicated than my linux skills, but I will give it a shot tomorrow if any of you have any tips I am all ears.

You mean you want the USB to auto mount into the gcode folder of printer_data?

Yes, one subfolder deep.

Did you figure it out or still looking for an answer? Please share if you have answer.

This page got me 90% there, https://linuxconfig.org/howto-mount-usb-drive-in-linux
sudo nano /etc/fstab
was the missing command to edit the file to make it permanent.
I had to link it to a subfolder in the gcode folder.

I actually killed my install but I think I know why trying to recover it now.

Here is the other half, between the two I think this is the right way to symlink the USB drive. Raspberry Pi Mount a USB Drive Tutorial - Pi My Life Up

OMG, that was a journey. I learned a lot.

Here is what works for my installation. The first time I messed something up and it would not boot.

I had to make a new pi image, run putty, add the old install SD into a usb microsd card adapter. edit that fstab file to delete my edit and try again.

Looks good, no idea why I am not getting the gcode preview image but it looks good. I have not tried to run one yet… that is next but it did survive a reboot. It does need to have a reboot to “hotswap” but that is pretty quick 30 seconds or so from the screen.

1 Like

I think that klipperscreen pushed the 3b+ pretty hard. I had to add heatsinks as I was getting temp warnings.

Really. I use 3b’s on all but 1 printer, well 2 now but Ive never gotten temp warnings on them and they run klipper screen. But they did already have heat sinks so maybe thats why

I am going to do some more tests today, try to figure out what is going on. My CPU was running high and hitting 100% a few times.

Are you running the lite OS version ( command line interface - CLI) or the full desktop? I install the lite version, then install KIAUH and install klipper and everything from that. If you have the full desktop, you can run raspi-config and switch it to command line startup where it won’t start the desktop, but klipperscreen will still work. Not sure if there is an order of installation here or not, but my systems boot command line and then start klipperscreen. I’ve got a zero2W, a 3B, and a 3A each running klipper and they all work fine. the v4 runs on a 3B.

1 Like

Yup lite 64bit, the screen runs through all the command line stuff with Raspberry logo’s, then some stuff without the logo’s then the klipper screen stuff boots up. So no full desktop snuck in that I know of. I will try the same file from mainsail directly to make sure it is not a symlink thing, I could have easily messed that up.

Fstab is pretty archaic, but it gets the job done.

I use ubuntu for the most part and it auto mounts most drives. I’m not sure which tools it uses to do that.

When that doesn’t work, I usually go to manual commands like mount, umount, sync, df.

You can also make the pi boot from USB. There are a few ways to do it. But you could make a USB drive be the OS, then when you want to edit printer_data, it would be on the usb drive already.

It is weird, without doing any of that I could see the files on the USB from the file editor screen (not sure what it is called), but no way to navigate to it from the gcode screen. So it does automatically mount, klipper/moonraker/mainsail does not let you browse. Seems sooo close but I guess it is just not something most people will use so why develop it??

Is it a permissions issue? Does that mounted folder have the right permissions for the klipper user to see it? In my gcode screen, I have sub folders and that can be navigated, but they were made on klipper, so probably not the same thing.

Did you mount the USB in the /home/pi/printer_data/gcodes/USB folder (where USB is the name you gave it).

Yes, that is the symlink right? It works now, after I did all that, just not before even though it was mounted.

I think the symlink points to where it is actually mounted, but you can mount it wherever you want.