OK, I'm stumped

I’m experiencing some (very) unusual behaviour with my LR3, and to paraphrase Bob Dylan - “Something is happening here, but I don’t know what it is…”. I’m hoping that someone here can point me in the right direction.

When homing upon initial startup, everything works exactly as expected. But after moving the gantry to the far end of its travel and then returning to origin, if I try to home again, one of the steppers will continue to move after hitting the limit switch. I know that the switch is working, because I see the LED assert, but the motor continues to try to drive past, hitting the end block and skipping steps until I unplug the power supply.

Some details of the build:

  • SKR Pro 1.2 w/TFT , 2209 Drivers (x5), TFT35 E3 V3 (all purchased from V1E)
  • Using V1CNC_SkrPro_DualLR_2209-2.1.1 downloaded from V1E Github

Everything was working normally prior to me making a couple of changes:

  • Modified the firmware to change from Portrait to Landscape (X is now the long axis, with Dual Endstops, and Y is the short axis with a Single Endstop (see Swapping X and Y Axis on a lowrider - #44 by Bartman)
  • Extended the limit switch wiring on the Rail Side by cutting the wires a few inches from the 2 pin Dupont connector and then soldering in a couple of feet of AWG 18 wire .

What is really confusing is that the X2 (formerly Y2) limit switch seems to trigger correctly, and it shows as asserted using a M119 command. It also works fine when first starting up, and will perform repeated homing commands at that time. But after moving the machine around for a few minutes, it seems to ignore the triggered switch and just drives the motor against the end block.

I thought perhaps there was some stray voltage on the switch wire extensions, so I twisted the wires to reduce noise.

I also was wondering whether the infamous SKR endstop pullup resistor issue may be at play here, but the board has been working fine for several months, and it does show as triggered when asserted. I can even watch the LED come on, then observe the motor continue to drive past the switch.


If the switch is showing as triggered by M119 then it isn’t the SKR Pro resistor issue.

I would be suspicious of the X/Y axis swap, that something has gone funky there.

Does it require the full motion travel? Does it home successfully 2 or 3 times in a row after being rebooted, or just once? Does it work if it’s already near home the second time? Does it work if it’s far away from home the first time?

1 Like

How are the wires connected to the board? Did you make connectors?

I wonder if they are moving enough to be intermittently connected.

1 Like

Thanks for the responses.

I did a bunch more moves and home commands, and the results were all over the place.

I was able to home upon startup multiple times (>5) with no issues, then I tried homing after moving to X = 500mm, 1000mm, 1500mm. 2000mm, all with no problem. Then I tried homing after a move to X=2500mm (Max X bed size defined as 2720), and it had the problem.

After restarting with X against the endstops, I tried Home All, and it had the problem right away. It backed up (recognized the activated switch), headed for home, then skipped steps on X2 for about 2 seconds, then stopped. I hit Home X again, and this time the X2 immediately started skipping steps (didn’t recognize the switch active). Each time the corresponding LED was active.

After the last test, I restarted and did another M119 with the X2 hard against the endstop and the LED active, and it showed X2 as not triggered…

I’m beginning to think that there is a very intermittent Pullup Resistor issue with X2, where it shows triggered sometimes, but not others. It is hard to tell for sure, because I can’t do a M119 command while the motor is skipping steps (shows as processing), and by the time I unplug or reset and restart, the problem sometimes clears and it shows triggered.

I don’t think that it is a connector issue, as the LEDs are showing properly, and the connections seem fine (using the connectors from V1E, re-soldered all of the extensions with a physical twist of the ends together).

I went over the firmware X-Y changes again, and I don’t see any problems there. It works as expected some of the time.

I think the next step will be to research the Pullup Resistor issue further, and to add the resistor to the X2 switch connector (and possibly to all of the others, although only the one seems to be acting up). I might also swap the X2 and Z2 limit switch port definitions in firmware (and physically), and see if the problem follows the switch or the port.

I crimped my pull-up resistors into the connector. Seems like a pretty easy thing to try and undo if it doesn’t work.

1 Like

So it seems from my research that intermittent issues with the endstops is quite common with the SKR boards. I didn’t want to believe that it was the SKR endstop issue, because I have been using the board for several months now and hadn’t had a problem. But with the newly added soldered cable extenders, it seems that the change in resistance may have been enough to tip it over the threshold.

I soldered 1.5 k Ohm resistors (x6) to the underside of the board. Not the prettiest solder job I’ve ever done, but it looks solid. I’m re-doing some of the cable extension solders and adding cable management (mesh loom) to everything, so I’ll test it a bunch tomorrow and report back.

Edit - next day and everything seems to be working fine! Stupid SKR voltage divider thingy…!


Sure that isn’t Buffalo Springfield (AKA Stephen Stills & Neil Young’s earlier band)? Specifically, For What It’s Worth? (I’ll cop to looking up the song name, but I knew it was Buffalo Springfield.)

edit: OK, nevermind. Never heard Ballad of a Thin Man before. But those lyrics seem to fit For What It’s Worth, which I’m much more familiar with… Mea culpa.

1 Like

“There’s something happening here, what it is ain’t exactly clear…”

Pretty much fits the scenario just as well as Bob’s lyrics (except for the part about the man with the gun over there, telling me I’ve got to beware…)

1 Like

But a naked man fits? And everyone thinks I’m the local deviant…