Odd issue, its like the x axis stops responding. (jackpot)

Hi Everyone,

I am having an odd issue that I have only just even proved what was happening and not stupidity on my behalf. At first, I thought I had taken a too bigger bite on the feeds as I only saw it just take off and messed up the board.
The second time I saw it, again I thought I had stuffed something up as it was just moving back and forward, but not sideways, and then it took off again through the work board.

So last night I had some time and loaded a simple model ( think something that looks like a horseshoe about 250mm x 250mm) and made it “air cut” and waited.
Everything started ok, but maybe the 2nd layer step-down to the third layer cut, it looked to just pause. But then it started again except the whole cut moved about 150mm to the right and continued to “air cut” to cut perfectly.
Next, I tried the same part that originally failed on, as the board is still on the surface. I went back to ESTLcam and used one of the peck-drilled holes as the centre point, re-saved the file, re-uploaded it to the jackpot, set the start point on the relevant hole and let it go.

It did the the same thing as the last time (not at the same spot), where the x seemed to stop working, while the Y kept going.

I am running the jackpot board. Standard firmware, not upgraded (if there is an upgrade) from when it shipped.
I am getting the occasional “out of memory” issues.
I have an M5 dial, BUT IS NOT IN USE as i am lazy and have not got around to it.

So here is what troubleshooting I have done.
Changed the laptop to my CAD laptop and turned off the sleep and screen saver (as i thought the issue might have been the super old slow laptop i was using)
Re-written the CAM as I have changed the start point to try and save the wood.
Tried a different CAD tool path (the horseshoe described above) and similar things happened.

I don’t think its a writing issue as, this time I stopped the process using the red circle arrow next to the actual file you are running, I know this is some sort of reset, but directly after that, you can home all axis.
It does not seem to do it in one spot of the gantry, maybe pointing at wiring.

What other things can i try/ give you to help me with this?
DO you want the cad files?

Its likely a physical problem, not software. If the tool binds for a split second you’ll get missed steps. When it frees up it will move in relation to where it thinks it is, not where it actually is.

Cnc machines are dumb, there’s no feedback loop to let it know it hasn’t moved so it just keeps processing gcode.

As to WHY you’re missing steps (assuming you are), that’s the hard part. Check your belts and pulley screws.

For the out of memory, there was a firmware upgrade a while back. It fixed the issue on mine. Once the file is loaded onto the jackpot and running you can get rid of the computer altogether. The board feeds the code, so your pc being slow doesn’t matter in this case.

Sounds like a wire issue.

The X stepper on the LR3 is a single motor, and is typically on an extension. Check where the extension connects to the motor wires for a disconnect. Check that movement of the X axis doesn’t pull on the wire at the control board, too.

Other things can cause the same symptoms, but this is one of the more likely…

Oh, and…

Check your grub screws! :rofl:

Edit: also check the X driver temp. The TMC drivers will shut fown for a while if they get too hot. I run the current on my X axis a bit higher to make up torque. The driver may need better cooling or lower current.

This is not quite accurate. It’s not the CNC itself, but the choice of motor and control that influences this. Open-loop steppers are dumb and have no feedback loop, but are relatively inexpensive to implement. There are motors that have feedback built in, and there are some examples here on the forums of people starting to use them, but additional “smarts” are needed to properly react to the feedback they provide. This can either be added to the firmware, or the device itself may include the feedback management. These motors tend to be a bit more expensive.

1 Like

thanks for responding @Nathan_Doty, @SupraGuy and @ttraband.

It could be the cables, but they are stranded cables so I don’t expect a problem in the cable , it could be the connections, well heck it could be the cable.
Next steps:
I will visually inspect the the cables and see if I can see anything.
I will run the AIR cut again and see if the X drive actually has power when its doing one of the failures I am seeing;
CHeck all the grub screws
See if I need to upgrade the firmware. (that will be a pain as I needed to make a few changes to the standard setup, like reversing motors etc, and didnt take notes)

And if I am doing that I am going to make the changes to the firmware that enable the M5 dial. - sigh - more reading to figure that out.

Have you checked with the machine powered down, that movement is free and smooth?

Have you placed the cut in a different spot on the table and see if the problem repeates?

Hi Nathan,

No to the first, i will check that and visually inspect the wires tonight as well.

Hmmm, actually no. Mostly.
I say mostly as I changed the start point on the original failure program that made me start to look at this. THe cut was kinda all munted, but its only shop furniture. So once I recentered that and ran that program again after resaving it in ESTLCam, it happened in a different spot.

I am going to be very focused on getting my LR3 dialed in now, as the GF just gave me a great idea for us to start a side gig that will require the LR3 and probably a separate lazer, so if I have to re-wire it I will. But I am hoping not!

But I have to dial in the LR3 and make it reliable. So I am probably going to look at a cable chain mod for that and the dust hose. I have a small space in my brother factory and he is moving, he has said he will give me a spot “for all my stuff” lol. So I might endup having to suspend my “workshop” ( a Ron Paulk workbench for my workbench and the internal door holding the LR3) from the roof, then lowering down. Bwhahahahaha

Laser next!

OH, I am so stupid at times, I just reailsed that I can just download the YMAL.config file thing and save it. then do the firmware update and reload the file, INCLUDING the UART changes for the M5 dial.

YAY for jackpot!

You wouldn’t be the first person to shift the entire thing from the center to the corner and find the problem disappeared. If you have a rough spot on a tube, moving the entire cut will bypass the problem entirely and help you troubleshoot. But if you move it and the issue keeps going, it’s helpful in eliminating one of the possible problems.

Missing steps is cumulative, and each step is tiny. You may not miss the same steps in the same place every time, but you miss 1, then 1 more then 1 more… pretty soon you have a problem.

Yeah its like layer shifting with 3d Printing.

The issues seem to be different, one issue with first cut job (then I moved the start point to try and re-use the wood) it seems to actually just not be moving the x axis.

then wen I tried a new program it did that “layer shift” 150mm to the right.

So I expect they are the same error showing up in different ways.
I will have more info tonight now I can see the problem.

I will check everything and hopefully is a simple “core to loose and grabbing” or something equally as simple to fix and find.

Ok first issue is the voard is
FluidNC v3.7.8

Current version is
FluidNC v3.7.12

So that might fix the low mem issues.

Now to upload the new firmware, i have download the config files, yay jackpot!

Checked the X axis by undoing the X belt, and it runs beautifully not even a hint of bind, even when trying to torque over the core. bonus, put everything back together.

Next firmware:
loaded FW with no issues and my config files were not touched, rebooted the unit and then homed Z.
No issues, its going in the right direction.
I moved the gantry in -Y 10mm no issues, again moving in the right direction.
I moved the core +10mm in x and the gantry tried to move, i saw it, but then it stopped.
Checking the core in now freely moves, like there is no power to the stepper.

Reset the LR3, same procedure, same result.
Reset the LR3, home z, all good. Home Y all good. home X, it tries to move and the stepper turns off.

So I suspect I have something wrong all along and my errors were this.
To the best of my knowledge I have not changed any other settings other than some pins and directions settings.

Oh and the drivers are warm, but not hot.

Time to isolate the motor.
Pull the x belt again and rapid move that motor, see if it has the same issue.

Then swap 2 of the steppers, see if the problem follows the motor or if it stays on x.

If the problem stays on x your issue is between the motor and the board. If it moves, it’s the motor.

Thanks Nathan,

Yeah, it will be pretty quick to change one of the motors out for say a Z, heck which every is next to it, lol.
Simple fault finding to start with. i ran out of time last night and wont be able to touch it for a couple of days now.

What is interesting is that the fault has grown worse since updating the firmware. before I was able to move it around and even cut things. I will admit that the fault seemed to be happening more, so that is pointing at the motor, but what is interesting is the rapid change to not even letting the X move now since updating the firmware.

The motors themselves are very robust. The fault is more likely in the wiring (including any extensions) to the motor than in the motor itself. Check each pin/crimp. I’ve had “factory made” crimps that grabbed the mostly on the insulation rather than the wire and the couple of strands that were connected fatigued through and broke very quickly. Frustrating, because initial tests all went fine.

1 Like

Fair call.

I will have to have another look and testing of the wires. This sort of fault finding is shit, but in this case its good as it now does it all the time.
It would be interesting to return it to the original fw and see if it works again

I have the same issue now. It just happened in the last few days, but I also went ahead and upgraded the xz plates and yz plates, so had everything taken apart and put back. After a few fits and starts, everything was running well. I started the first carve I was doing with a 60* vbit, and where I was usually mowing through material at 3mm depth, even at 1.5mm depth I was skipping X steps. I have upped the current, and slowed down to about half of the speed, but still. I did fray one of the wires to the stepper, and CA glued it back in, but I also tightened a lot of belts, and such, so I am not sure. The X tracks fine, but seems to be really low power/torque, so it’s either the wires or the over tightened belts. Grubs are tight. Can’t be the 2209, because I just replaced it.

Any feedback on 12v vs 24V power supply? I am running 12v 10A now, but I did also add LED lights to the bottom of the gantry that could be sucking up some current, but they are on a switch and I can turn off still having this issue. Pics related. Total mess, right now.

On the bright side, the LR3 is now SO much stiffer now after the upgrade, AND the Alternate T8 lead screws should be standard so the router doesnt drop on emergency reset - totally game changing. @vicious1

Did you splice it back together or just glue it?

You can turn the current up until the steppers hit 50C. The belts should not be very tight, 7lbs tension.

In what regards? 24v is slightly better.

I have not use an Estop in a very long time. I would rather have twice the Z speed than it not fall on emergency power down. I if E-Stop my router and board power off, so I don’t really mind if it falls and drills a hole. But When I run a 2 hour job every day with hundreds and hundreds of Z moves the added speed helps.

1 Like

The red wire to stepper motor broke at the connector, pushed it back in and glued. Probably not the best connection but I do have a replacement for that, so hopefully that was it.