Octopi/octoprint rpi

I feel dumb… This is my second attempt (technically 3rd because i tried the first on 2 separate occasions) at doing a rpi/octopi setup. first was the wifi zero that installs directly to the prusa. Second is the one i pulled out of the rostock i just got, Its a 3b maybe 3b+ but i dont see + anywhere. I have tried every solution i could find and hours of reading and trying different things. No matter what i do it REFUSES to connect to the internet. I have been back and forth from computer to rpi with my keyboard so much i just made a print on my rostock fail… I’m going to sleep.

It is a little tricky getting it connected. I have pretty good success with it (I’ve done it several dozen times) but I am very familiar with my router, network, and linux. If you’re not, then attach a monitor to see the text as it starts up. Near the end, it will post its IP address, or maybe give you an error message.

I was using it connected to my secondary screen.
I tried a several sudo commands and I have been testing if its connected by either running update in
sudo raspi-config
Sudo apt-get update
I all ways end up with the same temporary failure on all lines.

If you have access to a terminal you could have a look if you already have gotten an ip address assigned:

> ip a
  3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
  link/ether b8:27:eb:ff:52:31 brd ff:ff:ff:ff:ff:ff
  inet brd scope global dynamic noprefixroute wlan0

If not I usually just edit the file: /etc/wpa_supplicant/wpa_supplicant.conf and add my network parameters like this:


and after that you would have to restart the networking stack:

> service networking restart

If you have got an ip address but cannot connect to the internet you probably have a problem with the Domain Name Service (DNS). DNS does the translation from internet names to the coresponding ip addresses.

First try to ping the google nameserver:

> ping
  PING ( 56(84) bytes of data.
  64 bytes from icmp_seq=1 ttl=119 time=68.2 ms

If you can get a response from this server you are already connected to the internet, but the internet names probably cannot be resolved to ip addresses.
This happens to me when I am connecting the pi to the internet via my phone.

Try this as root:

> echo "nameserver" >> /etc/resolv.conf

And then try to resolve a name:

> ping www.v1engineering.com
   PING www.v1engineering.com.cdn.cloudflare.net ( 56(84) bytes of data.
   64 bytes from ( icmp_seq=1 ttl=59 time=65.2 ms

If that works you should be able to issue a “apt update” command.
To make the change permanent you would need to issue as root:

> chattr +i /etc/resolv.conf

Not sure if that all is understandable, but maybe it helps :neutral_face:

When I log in, octopi shows me a message like this (yours will look different):

The ip address and name will be different for yours. This is what I was talking about.

But raspi config should be able to handle it just fine.

The wpa-supplicant file is named octopi-wpa-supplicant.conf

Some of it is understandable but most goes right over my head.

This I have done this.

This is what mine looks like

Which just means it is not connected to your network. But you’ve avoided a bunch of problems by getting it that far. If you sit there and do the raspi-config, can you get it to connect to wifi? And if you reboot, it should look like mine.

Jeff for the win again! I connected through raspi-config which I had tried before but I didn’t realize it displayed the IP there after reboot.

1 Like

Thank you!

Now I’m in the process of getting touch UI going. It is suggested that I update octoprint before downloading the plugin. When I try it says “update not started”. I can’t seem to get it to update and I’m not finding any solutions elsewhere. There was a reference to power supply. every power supply I have tried gives me a undervoltage message except for when I plug it into a usb port on my PC.

All of the power supplies I have tried also say 5v 2a or more

Well nvm it appears I fixed it.

It appears to me as if with these cheaper/weaker power supplies the voltage drops for a short time under 5 volts when its under a bigger load. That is probably why the pi gives you a "undervoltage message ". For this reason I bought a pi certified power supply for one 3d printer and the other pi i hooked up to the 5 volt output of an old ATX power supply. This seemed to solve the problem.

1 Like

I also think the pi’s recommendation on power supply is a little weak.

Most of the power supplies I have that work well with the Pi are rated at 2.5a .


Thanks for the input guys. I’m using a 5v 3a and don’t seem to have any problems now. I did get an undervoltage message when I plugged my RGB Razer chroma keyboard but I think it’s just I little to much keyboard. Still got the job done though.

It took me almost 3 hours to figure out how to flip the screen. I had to flip the touch part of the screen and display part separately. Every other solution fail.

Screens on the pi are a pain. I have the official one on one pi and it is using the same power supply as the pi and I constantly have undervoltage issues. I solved it on my other pi by separating the power to the screen. Nothing else I tried worked.

1 Like

They are indeed a pain!

I have octodash on mine and now that it works, it works great.