Not going deep enough

Hey guys and girls.

No matter what I do I can’t get it to cut down to 12mm as I have set it in estlcam. Obviously the problem is me, not the software. I have set it to 2mm per pass at 12mm total. It does 6 passes but total depth is probably .2mm. Please help. Pleeeeaaassssee!!!

See favebook for video as file is too big for here.

.2mm? Is your z like, totally not moving?

It moves. No problem

So how is the total depth then so little? Does it move only a tiny bit at a time? Or does it retract? No idea here that’s odd

I think I’ve done something in estlcam. Z moves up and down freely. I’ll do another run and see if U can pickup anything weird


I just measured the Z movement. I told it to move (through the LCD) up 100mm, and it only moved 32mm.

I have to find the formula on what my steps should be changed to…

But I don’t think that’s the whole problem.

What control board are you using, what firmware is on it, and what screw are you using on your Z axis?

If you are unsure a picture of your board and your Z axis and we can fix you up, or uploading your gcode and we can check your settings.

1 Like

Try driving each axis separately without cutting anything and measure the moves to see if everything seems right with the hardware/firmware setup. This should rule out hardware and point to CAM if everything moves correctly. If not:

Did you flash the correct firmware for your Z axis screw? (5/16 allthread vs. T8 leadscrew)

Is the screw coupler loose allowing the stepper to spin but not the screw when under load?

Is the stepper skipping? Seems like you were using some out of the ordinary driver boards, what stepping rate are they capable of with the ramps board driving them?


1 Like

Or moving it too fast as in not setting the proper z rapid speed, usually this crashes the board but could just not take the steps. The g code will show this though.

Ryan I am using the ramps board with external stepper drivers @ 1/16 steps. Firmware MPCNC813_GLCD_T8. Allthread T8, not sure of the pitch but it’s fine thread.

I’m pretty sure I got it sorted now. I increased Z steps to 2600 and seems spot on. After I cut through a 12mm MDF, it only just made a mark on the spoilboard underneath. I still have to face the spoilboard to get it level but that’s for another day

Thanks for your reply also Mike. I’m using a T8 allthread and my stepper drivers can go down to 1/16.

Everything seems pretty solid and as I mentioned it all works now. hopefully I’ll try 4mm aluminium on the weekend. What feed and plunge rates would you recommend? I’m thinking of using the same 3mm single flute endmill, otherwise I have a 4 and 6mm 4 flute that I can use if that might be better???

You might want to get a lot more familiar with CAM settings , wood and plastic before you jump headfirst into the deep end with metal.

There are two long threads about this in the last week as well as a few in the FB group. Single flute, always start with single flute unless you have a reason to switch.

Metal is drastically different and the settings need to be spot on. At least do some plastic milling first.

Yeah I have some plastic I will try tomorrow and see how it goes

I ran in a similar issue.

Where is Z0 at the top or the bottom of the work piece?


In one of the cad programs I had to set target depth to -12. ( 12mm below Z0 )

Or did you set the firmware, that it can’t drive below Z0?

The software was already set to not go bellow Z0 but I changed it so now it is not llimited

The firmware is not limited.

Sorry I should’ve said firmware and all I did was disable the software endstops MIN to allow my Z to go bellow 0

That’s what I mean, my firmware is configured as is to allow negative movements without disabling anything.

Oh OK. Maybe I got a different version, modified, not sure. but I couldn’t get my Z to go bellow 0 unless I disabled the MIN software endstops.

Come to think of it, (I will check this today) but if I turn off the machine while my axis are in the middle for example, after I power on, I cannot move them back to the start because they are at 0. I have to turn the machine off, manually move them back, then turn the machine back on. Even selecting "Disable steppers"from the LCD doesn’t disable them, so I can’t even move them back while the machine is still on.

I’m using “MPCNC813_GLCD_T8”

Sounds like you have end stops plugged in wired wrong. The firmware is set to have them Normally Open.