Noisy stepmotors vibrates but not move

Hi Everyone,

this is my first post on the forum.

I started build of MPCNC but as a newbie I think I have some issue with step motors. I’m using mini rambo 1.3 bought here

and step motors, like below:


I flashed board with Marlin-MPCNC_MRambo_T8_16T_LCD from github. I connected only two step motors (X,Y)to check if I will be able to move it. I didn’t change anything in the configuration except BAUDRATE as initially I couldn’t connect to the board with Repetier-Mac. But the problem was with the driver, once I instal it everything was fine so I back to standard value 250000.

Now step motors start to move but I think there is a problem. Motors seems to could not find iddle possition after moving and gets noisy. For me it looks like some move parameters are wrong in the software or there is an issue with power input. Now I have no idea where to start , please advise. Below you can find screenshot from Repetier configuration.


Just to add one more thing mini rambo is getting quite hot , step motors stays room temperature.




It uses the board as a heat sync, so the back gets pretty hot. My printer has a fan blowing on the back side of the board. The motors will make noise while sitting still, that’s pretty normal.

I think still something is wrong. I wire now two motors together according to the wiring instruction nad the problem still occurs. Motors vibrate but not move at all. I disconect belt to check if the load is to big but still motors only vibrate without moving.

Below you can find move on that

If motors move properly, but you hear light high frequency noise when they hold in some position it’s ok. I have such noise with dvr8825 and don’t care - mpcnc works fine.

My 3d printer use tmc2100 and yes, it completely silent in this case (only controller fan produce noise)

Unfortunately step motors not move only vibrate as shown on movie

Disconnect the motor at one end and try again. The two may be trying to move in opposite directions.

Steppers aren’t wired properly. Unplug the power, then unplug all but one stepper. Test it. If it moves, then unplug the power, and plug in the opposite side stepper. Test again. If it does that, the stepper wires aren’t in the correct order. I have seen them come in with different color orders. It could also be one of the pins in the connectors came loose and got pushed out of the housing far enough to not make a good contact.

I disconnect all belts except one side X axis. I plugged only one motor on X connected with belt and one on Y completely free. Try move X axis but is shaking the same as on the previous movie without moving. Free engine is moving a but more but irregular and if I’m touching the wheel immediately stops and there is no force from motor. I tried also to swap connection plug on the board but nothing change still more vibration than actual movement. I have radiators on board chips but still get extremely hot (measured around 80degree Celsius and switch off immediately).




I would check that you have the wiring done correctly. It looks and sounds like there’s either a bad connection or it is cross-wired.

Yep, wires aren’t correct. You’ll need to figure out the correct wire pairs for your steppers.

Also, remove the heat sinks. The chips are designed to use the board as a sink, not the top of the chips. Blow a fan on the bottom of the board for cooling.

Zieluch, I had EXACTLY the same issue you’re having just last night trying to get my MPCNC up and running.

My problem was exactly what Barry and BT are saying… The wires are in the wrong order in one or both connectors. It’s quite easy to remove the wires, and swap them around. The trick is figuring out where they should ACTUALLY go. On mine, I wound up removing all 4 wires from one of the connectors and swapping two wires around on the other end. My machine works fine now (Jogging anyway, haven’t gotten to cut/draw anything just yet. Working on that now. Motors are quiet and smooth. So it sounds like you have some wires crossed. That’s a common issue it seems, as there seems to be no standard for color coding on steppers.


1 Like


I disassembly motor and looks like on picture below and i wire it blue, red, green, black. From option which I tested I think this is the best but would like to confirm with someone more oriantated.



It looks like the connector should be wired blue/black/green/red. The easiest way to confirm is to either do a continuity check with a resistance meter or take two of the wires and hold the conductors together - if the motor is hard to turn then you know they are connected to the same coils and should be adjacent to one another on one side of the connector.

1 Like

Thank you BT your tip was very helpful. I hold two pairs and check resistance on motor (motor hold shaft once it is correct). Pairs are black-green, blue-red. Now X-Y is working very smooth as expected. Now I have problem with Z axis. I changed the cables but Z motor is not working smooth (I tried all possible cable combination but this one was definitely fine). I remove motor leaving only screw and it is not working smooth but once I connected Z motor to X slot on board (single slot in mini Rambo) and everything work much much better (As expected). For Z access in miniRambo I have two slots I checked both in both same problem, should I wire it differently?

Thanks Michal

Do you have the z-axis motors wired in series instead of in parallel?

The miniRambo has two connections for the Z stepper because it is designed for a 3D printer that has two steppers for Z. You can just ignore the second. If you are feeling roughness in the Z axis movement with the stepper disconnected then you need to look at your mechanics, not the electronics. Be sure you have all the parts assembled correctly and that the lead screw is straight with the nut screws a bit loose so it can float freely. Lube the lead screw with something like white lithium grease and try again. It should move smoothly for the entire travel with just your fingers spinning the lead screw.

As I mention the problem is with electronic as the Z motor is not moving smoothly dissembled from machine, only with T8 screw attached. Once I plug this motor into X or Z it is working much better.

Any idea what might be wrong ? Connecting Z motor to X or Y port on mini ramo and Motor is moving quite well but connecting to one of the Z port (tried both ones) and motor struggle to move, more noise and vibration than actual move (maybe for first 1 sek after switching power on is working correctly).

Below things which I tried:

  • replace pins and plug with new one
  • found pairs of cable and tried all possible connections (i have 5 same motors and order used in other 4 motors seems to be the best)
  • tried both Z slots on mini rambo board
Last thing which came to my mind is maybe I should prepare cable to connect Z motor to both slots ? Does anyone have schema for such cable ?


Have you tried plugging the X or Y motor into the z-axis port?

I played a lot to solve the problem. Once I connect X or Y to Z fuse step motors move smoother but much more then expected (sending 100mm to move and it is going almost 400mm) Next thing which I put back Z motor and change PWM_MOTOR_CURRENT (900,450,900). This allow to actually move Z motor, it is not ruining super smooth but it is moving. I decided even to draw crown but without any success. motors not ruining smooth etc.