No Response From Repetier-Host

I just finished my first MPCNC build and am having trouble with testing it via manual control in Repetier-Host. When I plug my board into the wall and my computer, I have no trouble connecting. However, when I click a manual control option, nothing happens. My baud rate is set to 250000 and I have the latest firmware flashed (I think.) I don’t see any errors in the log, but occasionally commands appear to ‘stack up’ and I will have several commands waiting.

I did not buy anything apart from my wiring harness from here. I printed my parts myself and ordered electronics from Amazon and other sources.

P.S. I’m a complete CNC newbie, so please fully explain any suggestions.

Mac or pc? Some mac’s can’t handle 250000 for some reason.

Your mosfets are touching, separate them or if you ever apply power to the other side you will let the smoke out.

PC running Windows 10. Sorry I forgot to mention it. How do I separate my mosfets?

The three black and silver bits above the blue strip, the metal on them can not touch.

If it is not a mac or some sort of windows tablet thing it should work. It flashed the firmware fine with no errors?

Mosfets no longer touching. Still no movement. Firmware did flash correctly. It’s a fairly normal laptop.


Does repetier show an extruder temp?

You might have to change the baud rate and go lower or try a different USB cable, and or port.

Repetier-Host showing 170 degrees. I plugged in my LCD, and when I move the machine with Host, the movement registers on the LCD but the machine doesn’t move. Could it be a power problem?

Yep. The motors get power from the 12V, the arduino gets power either from the 12V to 5V regulator or the USB. So if you disconnect the USB, does the arduino and LCD stay on?

Alternatively, it could be something wrong with the drivers, or something wrong with your motor wiring. Are there any noises when you try to move them?

I had an issue with a cheap Amazon power supply. It was rated at 12 VDC 6A, but barfed any time I tried to pull more than about 2A. Double check that your supply can actually supply. :slight_smile:

Resolved! All I had to do was change outlets.

Well that’s worrisome!

Maybe not. If the 12V was plugged into a dead outlet, then the Arduino and LCD were getting power from the computer, but the motors weren’t. If the outlet wasn’t dead, but it somehow couldn’t handle the 0.5A the power supply uses, then… Yeah, worrisome.