No-radio version of FluidNC firmware with CNCjs grbl sender

I built the no-radio version of FluidNC and noted that the bin file was 43% smaller compared to the wifi version.

Then I sent the test crown to the jackpot board over usb and everything worked perfectly with no low memory warnings. After enabling reporting in the usb console, CNCjs did a great job of displaying the current tool position and buffered gcode.

Using hardwired connections to send gcode is my preference due to some of the motors in my shop emitting EM noise that can interfere with wireless connections.

6 Likes

That is a good point. FluidNC is great. And Wifi is convenient. But having the hard connection and not including the wireless should make it much faster. The ESP32 is way overpowered for this application because web service is hard work for microcontrollers. But if you take that out, you have a dual core, 240MHz 32bit processor for stepping some motors and one uart connection. Which is very much overkill.

I’m not sure we could get away with making this the default without giving some non-computer option (like a screen, but the screens have their own cons)? But it could be well documented for advanced/experienced users. It is probably easier for most beginners to use a wired connection, but getting into windows or mac support can be really hard.

2 Likes

This would work great for my laser setup. Its literally mounted right next to a desktop computer so running a USB cable to it would be simple.

What is the reliability over USB? I have had multiple instances where running a 3d printer from octoprint and it crashes part way though because it lost connection to the board. Now that wasn’t this board or an ESP32 so it might be non issue.

It should be very reliable although the choice of sender could seriously impact reliability. Grbl originally only supported serial connections whereas fluidnc extended grbl and added more comm options such as wifi or bluetooth through their channel interface. I’m still working my way through the fluidnc code and want to confirm how sending gcode over usb or other channels implements retries or buffer full.

Here’s an article on grbl gcode senders:

GRBL can reliably pass lines of code to your microcontroller through a USB cable.

https://modernweb.com/best-grbl-software/

2 Likes

I struggled to get cncjs in usb contact with the FluidNC, with web server and wifi running. I don’t know if it was my fault or limits to the system. Running the fluidnc without all the extra head would certainly be a dream! Using FluidNC for plotting has been great, but the memory hickups would terrify me if I was using a laser! If I do big plots it starts to pause towards the end of the job.

2 Likes

So how would you rip out the web parts? Is it like arduinos where you can customize? Once it is there the server portion still takes up resources used or not.

1 Like

There is a no-radio version in the releases. Presumably, they build it with slightly different flags that determine which code gets included.

And yes, it is open source. So you can change what gets put into it and customize it before building your own image. It is very similar to arduino, but my guess is FluidNC has not make any effort to make it build in arduino and they use platformio instead.

2 Likes

Any shot at getting some instruction on getting this set up? CNCjs is my standard go to for my other cnc and if I can keep the same workflow for both it’d be a big time saver. I was hoping it would be just plug and play, but it doesn’t seem to be that way.

It should just work, even with the Wi-Fi enabled. Just connecting over usb should act just like a grbl controller.

3 Likes

I would love it if it did!

I can find the USB from silicon labs, but when I connect to it with the GRBL tab I get:

CNCjs 1.9.23 [Grbl]
Connected to /dev/ttyAMA0 with a baud rate of 115200

That’s it. I cannot move anything, home anything, zero anything, etc. I’ve tried moving the baud around to no avail.

I just received this jackpot from v1 yesterday so the flash should be current. I can get into the webui, but it’s pretty lacking.

Pretty sure you need to unlock it in lightburn after you connect…I wrote it down somewhere.

The other way to use this is put the output gcode on a memory card and run it from a web browser.

You can home $H, or unlock $X to use lightburn directly. Did you see the note in the docs about turning off wifi if you are directly connected?

Sorry not sure why I assumed lightburn, same applies though. You might need to unlock or home before it will move, it is a safety feature in some programs.

1 Like

You should probably start a new thread on this. Give as much info as possible. So if I read above I see you say, 1)It is a new jackpot board, 2)you cannot use cncjs for movement, 3) it says you can connect to the webui, but did you try using it?

For lack of movement, my problem was I do not use endstops yet, so I had to turn them off in the config.

Also please in the new thread post your yaml you are using.

2 Likes

Will do.

1 Like

You should be able to. I think Mitch had a role in that dev, I think, so I am pretty sure they keep that channel working.

New thread is a great idea.

OHHHH, soo sorry, I was just bulleting the statements above. I am very sorry, I was not trying to say it cannot work. I will edit my statement above!!! Ugh!

I was wondering the same i use UGS and will later today be trying the same just recently went back to work for a few months :upside_down_face: then back to retirement. So busy busy right now :sleeping:

I’ve definitely used fluid nc with v1pi before over usb. It has been a while though.

1 Like