No Printer Attached issue

Hello everyone, long time lurker, first time poster…

Finally finished the assembly of my LR3 and found problems with the dreaded “No Printer Attached” message on the TFT. I’ve trolled the forums here and tried what worked for many others:

  • disconnected cables except for input power and the black serial cable
  • downloaded and reinstalled firmware for both SKRPro and TFT35 (both purchased from V1 shop a couple months ago) - extension changed for both sets of files so I presume they were successful (no change of operation)

Behavior is consistent - after clicking the BigTree Tech icon and the menu appears with the red “No printer attached” message at the top of the screen. None of the icons are clickable and the screen quickly reverts to the startup menu you get after power is initially turned on. Clicking the icon multiple times eventually causes the TFT to sound a continuous loud tone until I hit the reset button.

One additional thing I tried - I mapped the wires between the TFT and SKR board and it appears that the RX pin on the TFT goes to the RX pin on the SKRPro (same for TX). Normally I see these swapped so I swapped pins 3 and 4 on the SKR end but didnt help.

During the troubleshooting I also reversed the four pin connector on the SKR side, but the TFT wouldn’t turn on.

Any other ideas?

Thanks for the help!

1 Like

Please remove the TFT cover, and then provide close up photos of the cable connections on both the TFT and Controller. That will help to determine if the pinouts are correct.

Congratulations on finishing your LR3 assembly!

We’ll work this.

Downloaded from where?
When the TFT powers on, do you get a red V1 logo?
The firmware on my TFT displays a different menu layout, so I suspect you may not actually have the right firmware.

The correct location as I type this is

Some additional troubleshooting steps:

Can you go in and check the UART speed is set to 250000?

Is there a reason you didn’t hook up the grey Marlin mode cables?
It’s sometimes helpful to long press the TFT knob on startup to switch between Marlin mode and TFT mode when troubleshooting. They use different interface methods back to the SKR.

Agreed, but if you have power up on the TFT and only the black cable connected, you pretty much have to have it correct.

I had the same problem Look at your microprocessor you have the ST On the main board You need a firmware without the the Gd

If OP is mixing and matching individual wires, it might get power but no data communications. But yes, proper firmware for both units, and proper baud rate are very good places to start.

And yes, good idea to connect the gray cables also. As mentioned by @MakerJim , if you can get one mode working and not the other, it can pinpoint some troubleshooting issues.

Great first post! Thank you!

Hi Bartman!

Here is a pic:

Hi Jim!

V1 logo on powerup is red:

I downloaded the firmware from the V1 GitHub links on the SKRPro page - (3/2023)

From the TFT package, I chose BIGTREE_TFT35_V3.0_E3.27.x.bin first and later tried the GD version as my TFT has a GD chip, but saw no difference. The config.ini specifies 250000 (option 7), I have no idea how to check the SKRPro side.

The grey cables were installed with the rest initially but removed all other cabling as suggested by Ryan in another post. I reinstalled the grey cables and tried to start Marlin - it opens, some numbers change to ? and closes back to the boot screen.

Long press of the TFT knob only produces a chirp.

Sorry, forgot to mention I swapped the wires back after that test. Black cable is back to its original config.

You don’t need to choose put them all on the card and the screen will use the file it needs. I am thinking you might have missed a file.

If you bought this from me, I flashed and tested it before it left. For anyone reading this in the future if you are having issues with set bought from me please do not flash it unless we ask. John, no worries we will get it sorted out.

Please take the screen out of your box, I think it might be messing with this, My screen mounts do not use the screw holes for this reason. And that kill button could be pressing the button.

Can I see a close up of the wires as connected to the SKR Pro as well, I want to see where the single wire is and if the ribbon is twisted.

Hi Ryan!

I took the screen out of the box, here is the pic:

I also tested it this way and I did not get the error message! Hard to believe the case is the problem, I dont see anything the screws can short on either side of the board - strange. I’ll try installing it again and see if I can identify the problem screw, at least until I reprint the box.

Also, regarding the firmware, which versions should I be using? Want to make sure they are correct before proceeding.


Your picture is not clear/bright enough to see the single pin on the skr

It has been before.

The doc links I sent should be pointing to the current ones.

Sorry, hard to get everything in one frame… the single pin is on the right side on the SKR board.

Try flashing the screen again, leave all the files on the SD card this time.

Partial success, two of the three updated but not the bin file, tried three times with same result. Even formatted SDCard before the last one…

Wondering if BIGTREE_GD_TFT35_V3.0_E3.27.x.bin is the right one, given the Info Screen above. There is a GD chip on the TFT board, but the info screen may just be identifying the current firmware too.

If you leave every single file from my zip on there the screen uses the file it needs.

Your card should look like this,

Ah, ok, I can try that. Wasn’t sure what would happen if multiple binaries were present. Updating card now…