No movement from any axis

Purchased Ramps/Mega and wire harness from here. Steppers and power supply are from the amazon links.
Arduino software was already loaded.
-Plugged in axis wires
-Plugged in USB (computer picked it up immediately) green light on Mega lights up solid and green light on ramps blinks once. Mega2560 shows up in device mangager as com7 N,8,1 9600. Arduino software confirms Mega 2560 on com7
-Plugged in power supply (wired to ramps board).
-Loaded Repetier Host (it also loaded server) set up Printer Settings exactly as pictured on the “basics” link on this website.
-Clicked “Connect” and the icon turns green and the status bar at the very bottom reports “Connected defualt”
-Under Manual Control tab, I click on X to move 10 and the heading bar right under the Manual Control tab says “4 Commands Waiting” Shortly thereafter the log reads “Communications timeout - reset send buffer block” then the heading bar changes to “1 Command Waiting” and then “Idle.”

Below is a copy of the log:

15:28:21.684 : No start signal detected - forcing start
15:28:21.686 : N1 M11034
15:28:21.686 : N2 M115
15:28:21.686 : N4 M11435
15:28:21.731 : N5 M111 S6
15:28:21.734 : N6 T060
15:28:21.734 : N7 M80
15:29:07.843 : Communication timeout - reset send buffer block
15:29:07.843 : N12 G9134
15:29:07.843 : N13 G1 X10 F3600
15:29:07.843 : N14 G90*37

I HAVE NOT flashed anything on the Arduino because the shop page here says it is already set up, flashed, and tested.

Not sure why at all, but it is working now. Yay! I think

Might have been a serial port speed mismatch. I had to set my port up with 250000bps to talk to the Arduino.

Thanks for your response Bill. I am almost 100% certain you are correct. I tried setting the baud rate in Repetier to match that of the com port as shown in my device manager and that does not necessarily work. I put Repetier at 250000 which appears to be the default and the only time I have had trouble since is when I again tried to match the rates.
Recapping, no matter what I adjusted the com port baud rate to on the PC, I only got a clean connection when Repetier was set to 250000.
I am having a ball with this machine.