New release version of FluidNC just dropped


Repository: bdring/FluidNC · Tag: v3.7.17 · Commit: b608a43 · Released by: github-actions[bot]

  • Config Alarm: FluidNC starts with a config alarm if there were problems in your config file. This can be cleared like other alarms, but it help users understand that there are problems that need to be fixed.
  • Error Reporting: Errors display with a full description in addition to a number. This can be controlled with the verbose_errors: config item.
  • Homing Current: TMC2209 drivers now have a homing_amps: config item. This could be helpful to people trying to tune stallguard homing.
  • Probe: Fixed some probe pin issues. It now has a hard_stop: config item. This will hard stop the motion at the probe contact point. It prevents deceleration overtravel to protect fragile bits. It may be less accurate at higher speeds if deceleration is needed.
  • Homing: You can now set the number of homing touches. The config item is homing_runs: and the default is 2 to match the traditional method. It can be set from 1 to 5. The first touch runs at the seek speed and the rest run at the feed speed. Some features like stallguard homing do not benefit from multiple touches.

This release has 7 assets:

  • bt-firmware.elf
  • noradio-firmware.elf
  • wifi-firmware.elf
  • Source code (zip)
  • Source code (tar.gz)

Visit the release page to download them.

Caveat: I’m not vouching for the new release’s stability etc, just saying it’s there. :slight_smile:

Completely off-topic, but this word has got the weirdest, non-intuitive pronunciation of any English word, ever. And there are a lot of weird words in English, being the bastard child of all the countries and cultures having invaded Great Britain. :stuck_out_tongue:

The English language has tons of borrow words from other languages, many of which seem strange in their pronunciation, and apparently (based on what I’ve been told) I use them all. LOL

My 6yo is learning to read and whenever something doesn’t fit the rules she says, “It must be French”. She’s often right.

My wife was a big reader when she was a kid. So there are a lot of words that she didn’t know the pronunciation for. Sometimes I catch her saying something weird.

But, on the flip side, she has a much better vocabulary and spelling than I do. Sometimes we do queen bee together and she easily gets 5x more words than me. I also constantly come up with spellings and words that don’t exist.


That’s just the Shakespearean approach to the english language.


I here’d dat!

1 Like

My wifes mother was a war bride fron London and the weird gramer and words to come out of this is unbelievable and wonderfull.

1 Like

There are a ton of english words i don’t know the pronunciation of… but then I remember i’m french, so I don’t care :rofl:

1 Like

IMO, that’s both a feature and a bug of today’s English language, frustrating for people learning to read and write English but at the same time the idiosyncratic spelling of some words is a clue to the word’s etymology and that can often help one understand the word’s meaning and usage.

Every now and then you hear some people suggest that the
English spelling should be rationalized and that every word should be spelling phonetically, as a native English speaker, I hope that never happens, I think the idiosyncrasies, while occasionally frustrating, tell a story and add to the richness of the language.

1 Like

I’m sorry to interrupt your parley on English language, but I have a fluidNC question. I’m running fluidNC on a mks dlc 32 v2.1. When I updated to v.x3.7.14 a while ago, I lost the ability to jog using the keyboard! The keys light up on the WebUI, but there’s no movement. I tried asking in their Discord, but got no replies. Anyone else experience this?

I haven’t had that happen.

Have you tried going back to the previously working release to show it still works on your board with the older version (no reason it shouldn’t).

Is it still broken for you with 3.7.17?

This might be one of those cases where you run the erase(.bat or .sh depending on your OS). Then put 3.7.17 on, then put your config.yaml back, then any other changes.


I reverted to an older version (3.7.8), and same issue there. The newest .17 is the same. I guess I have to do a erase then! Is it possible to erase over wifi, or do I have serial to connect?

I’ve only ever been able to do a full erase over USB. If someone else knows a way to do that over WiFi, I’d love to know how…

1 Like

Guess I’ll pull out my extra long usb connetor type B cable then. Thanks! :smiley:

That’s funny… Makes me think of home, New Orleans, where half of the street names are French spellings, but English “pronunciations”. i.e.: Freret St. is “Fer-ret”, Carondelet is “Ca-ron-de-let” and don’t get me started on accented syllables. Is is BurGUNdy, or BURgundy? CalliOPE or CalLIope? (Told you there was Greek in there, we have all the muses, and where the accent falls is dependent on where you grew up.) And just for fun, there is an old, old joke about a policeman who dragged a dead horse a block and a half to a different location because he didn’t want to put “Tchopitoulas” on the report (I lived half a block off of Tchopitoulas for a couple of decades, and for a few years, Big Chief Jolly and the Wild Tchopitoulas Indians started Mardi Gras at a little dive bar across the street).

not to be the spelling police… but… (native Louisianian here too)

part of what makes it harder to pronounce is that it is spelled


so it’s harder to make out the “chop” when you read it the first time

Yeah, yeah… It’s also been over 20 years since I lived there, and probably at least a decade since my folks sold that house… :wink:

But yeah, the “Tchoup”/“Chop” gets folks a lot. Even natives say “Te-chop-a-two-las” a lot…

And to make the socio-political obvious statement, the joke was originally overtly racist and/or xenophobic, depending on the race or country of origin of the policeman; we are talking about a joke originating from the late 19th/early 20th century New Orleans, in the Deep South, where in the 80’s I remember going to the CSA (Confederate States of America, you know, the losers) museum just off of Robert E. Lee circle (where they later had to get a big crane to take him off his huge pedestal during the BLM heyday), as a private (nominally progressive) middle-school field trip.

OK, enough work avoidance for today, I think…

1 Like

History is not always what it looksike at the time.

Colorado has a lot of Spanish towns and the towns are now full of English speakers who butcher the pronunciation. I heard that Burna Vista officially declared their town was pronounced the English way (which I can’t ever figure out). Which is a big shame because it sounds so pleasant in Spanish.

I did a full erease, and restored with my config file and updated preferences. But the keyboard still doesn’t work. Perhaps I should file an issue on github. I’m just a little daunted by their issue-procedures, they are quite detailed! (Which is good, of course!)