New problem with Marlin, auto home not working

Im ready to trash this thing already. Nine out of ten time the auto home wont work with one or two motors not working. Then it will auto home correctly. But the one time it does that, when i go to run a program, it will jerk inward beyond the stops and not move from there. I have successfully run some carves but now its nothing but problems. Im fairly new to this and am out of ideas. Thanks for any help.


I’ve been on the forum for a couple years, and when others have the same problem it is often one of these issues:

Wiring/connectors are intermittent, or if they are not shielded, there is some random EMF that is leaking into the wiring causing the signals to get garbled.

Are you running a vacuum hose near the wiring? the static buildup can also mess up the signals.

What controller board are you using, have you checked the Dupont connectors to insure they are making good contact at the board?

I’m sure several others will chime in with additional areas to check.

Mike B.

I’d start with any part of the physical wiring that moves when the machine moves.

I recently had problems on a 3D printer that had been running fine for years. Turned out the tape that held the dupoint extension to the Y motor connector had let go, allowing just enough movement in the connection that homing the Y axis failed occasionally. As soon as I replaced that tape, everything went back to normal.

If I understand correctly that your machine, when homing, has the switches pressed by the stops but the machine fails to honor those stops, then there are a couple of things to consider. I’m assuming you have a “standard” V1 firmware version where the endstops are wired normally closed. First, if it is a wiring issue, it means your wires are shorting rather than an intermittent connection. This is harder to do, especially in an intermittent fashion. Second, this can happen if your endstops are not plugged into the correct sockets. For example, if you swapped the plugs for the X1 and X2, then the endstop would be controlling the wrong stepper motor. It would appear to almost work, but you would could have strange behaviors like one end pushing past an endstop.,

Thanks for the help @ttraband @robertbu . I checked all the wiring and connectors that I could find. After a bunch of playing around unplugging and plugging back in everything i could find, thats my no knowledge approach to fixing things, this is where i am at; z axiz is good, x axis is good, y axis, not so good. I can go in and move the y axis and both motors respond, but when i use the home function, only one y axis motor responds, x and z axis respond correctly. Once again at a loss lol…

What does M119 show in the repitier console?

So, it appears the wiring to one of your endstops for the Y axis is not working. Start by sending a M119 to check the endstop states. If it reads “triggered,” then you have an open connection somewhere or the board has a problem. V1 maintained firmware expect normally closed connections. It may be the switch is wired wrong. There have been some quality issues with the endstop wires that come with the Rambo board, so don’t assume the wires are assembled correctly. There may be a break where the endstop wires connect to the “harness.” You can test the board by jumpering the endstop pins to simulate a close connection and using an M119. You can test the wire using a multi-meter.

If it does not read “triggered,” then electrical noise is the most likely issue. Electrical noise can be addressed both by modifying the firmware (Marlin), or by adding a bit of hardware.

Hi Robert.
Thanks for taking the time to offer suggestions. I don’t know how to do the M119.
To update, the cnc was working properly last time I used it. The Y axis, I am able to move from the control board. When going to auto home, only one motor works. I switched the plugs on the board and that resulted in the motors doing the opposite, the one that didn’t work now worked and the other one stopped so I’m my very limited knowledge, thinking the board has issues.
Tried it again the other day, now auto home decides to work. But when I go to start the program, the router jerks quickly into the x and y stops, pushing the origin in to a negative position if that makes sense. Just at a loss and doesn’t help I don’t really understand much of the computer side of it.

One of your endstops are being triggered. The firmware is set so they are normally closed and that when triggered they open the circuit. If a wire is unplugged or a wire fails, then it becomes triggered. This way you’ll know when you home that something is wrong, rather than you trying to home and crash everything.

You can use a volt meter to check continuity in the wiring. If your y1 motor is failing, then it’s the y1 stop and vice versa.

Do you interface directly with the mpcnc? If so with what software? M119 will check the endstops. Let us know what software you use.