New Primo Build - won't move!

So I finally finished the main hardware of my primo build and temporarily wired everything up for test purposes (need to run longer cables, end stop cabling, and drag chains etc. in due course; the electronics will eventually end up within the base of the machine once fully sorted).

I have the SKR Pro 1.2 with the TFT35 V3 (not E3) screen, and2209 drivers. I didn’t get them from V1 but successfully flashed the V1 dual end stop firmware onto both the board and screen.

Everything powers up and I can use the screen in touch and marlin mode. In touch it briefly shows ‘not connected’ but that goes away, and I can run the M119 command which shows the end stops as being triggered (as expected as they aren’t yet connected) - which to me suggests it is connects to the board after all.

So far so good.

The problem comes when I try to jog the motors to tentatively check everything is working. When I use the move command on the touchscreen, say to move in the x or y axis by 1mm, on the first go at least one of the motors ‘clunks’ (one or more stepper motors being energised I assume), but there is no movement. Then I get some beeps and the screen displays “printer halted; kill() called”.

I tried moving via Marlin mode and get the same result.

All 5 stepper drivers have a little red LED next to them when the board is powered. I assume this means each has power.

As I mentioned, the end stop microswitches aren’t yet connected, and I was going to short the connectors on the board to fool the board into thinking they are connected and made, but I read that the software only checks their state when homing so I presume it shouldn’t make any difference.

Any ideas?

Thanks in advance,

I made the same mistake.
The end stops must be connected for movement.
The red LED’s indicate a triggered end stop.
And by the way, that is a very neat build.

It should move fine without the end stops as long as you aren’t trying to home. Did you get your steppers from Ryan or somewhere else?

If somewhere else you might have to flip the middle 2 wires. Have seen that a few times.

My first thought is to check the 2209 drivers and make sure you cut or bent the correct pin and that the jumpers under each driver is set correctly. If it goes to kill when the motors are activated then it is a motor wire as mentioned or a misconfigured or bad driver.

1 Like

Thank you all for the quick responses. Here are photos showing the jumpers and what pin I bent on the 2209 drivers (obviously the same on all 5). Looks to be the same as the build instructions.

I could remove each one and double check but it seems like a common issue rather than a single driver. Is there some command I can send which can run a diagnostic on each driver to confirm this?

The only slight anomaly is the build instructions were for a V3 E3 screen, mine is a non-E3 variant. I cross checked the EXP1 and EXP2 connections on the BTT github and they are the same. The only difference seems to be the black ribbon cable connections, which seemed to be reversed compared to the pictures on the build page. In any case I ensured that the 5V was connected to 5V, GND to GND, etc. etc. Given the TFT can send and receive info, and the issue occurs on Marlin mode too, I assume I connected it fine and it couldn’t cause the issue anyway.

I got the drivers together with the screen and SKR board as a set from Ali Express.

I’m currently using the stepper cables that came with the stepper motors. Here is how they are wired - I can swapping the middle two pins that but will be a bit fiddly de-pinning these ones or making up new cables so would like to confirm that’s the issue before committing to it…

I did do a minor booboo … after wiring up I moved the core a few times and then noticed the screen briefly flash and LEDs light on the board. I then realised that driving steppers can spike components and promptly stopped doing that! Annoying as I’ve always been careful with this with 3D printers.

However, it was only the briefest spike, and the board clearly works. I’d be amazed if I have somehow killed all 5 stepper drivers from that one incident (especially the Z-axis, which I didn’t move…).

As long as you did a short movement the steppers do not generate enough power to damage, I’ve done it several times on 2 machines, no issue

OK, reviewed the entire thread. Have you checked the fuses on the board? One of my 3 SKR’s had a bad fuse many years ago, and it took me a bit to look at that as the issue.
Also, re-seat the ribbon cables to the LCD, confirm they are in the right sockets and make sure the black one is oriented correctly.
Another thing I’d try is removing the black plastic socket around the X stepper plugin on the board, there have been issues with those molex socket brackets causing bad connection. They come off easily with a needle nosed plier, gently rocking them and slipping them off.
After all that confirmation, then try in the terminal on the LCD, G0 X10 (command to move X 10mm) to check movement.

Thanks John.

  • Checked continuity of all 3 fuses: all good.
  • Check ribbon cables, all good. Checked black one - happy. (5V to 5V, GND to GND, RX to TX, TX to RX, RST to RST).
    I removed one of the black sockets on the X stepper. Definitely has a much more positive connection now. (I do intend to use them as when I make up custom cables I have the right JST connectors to fit those sockets, but happy to remove for now.)

I did the move command and helpfully the screen dumped a load of diagnostic info… and I think I’ve found the culprit:

Connections all look good…

but… looks like I have a bad driver?

Fortunately the pack came with 6 drivers so I’ll swap the X driver over with the 6th and see what happens…

@Jonathjon was spot on - armed with the ‘coil short circuit’ error I was able to do some more focused googling, which led me to check the stepper coil/pin configuration vs the pins from the drivers. The stepper motor wires (that came with the steppers) did indeed need modifying by swapping the middle two pins over.

It now moves! Now to wire and install electronics properly…

Thanks for the help everyone.


well glad we could help out