New fusion 360 update breaking post processor

With the new fusion 360 update I now get the error that the marlin post ( is a “invalid post processor” , I worked just fine and nothing changed other then the fusion 360 update any ideas?

machine: lowrider 2 w/rambo
software: fusion 360 hobbyist 2.0.11415
os: windows 10

Sorry if this seems like a stupid question still new to this.

I just create a 100x100 square and was able to generate a tool path using guffy and flyfisher604 Post processor. No problem here… My LR also run on a Rambo and I use the same fusion as you. the only difference is that I’m on a Mac. Not sure when the update was send out and if even hit my F360 yet.

This is what the updated ui looks like for me. Edit I am on version 2.0.11415

Ok I found the fix for anyone on 2.0.11415 you have to redo the machine setup
move the post you want (and the JavaScript file) to \Users\YourUserName\AppData\Local\Autodesk\Autodesk Fusion 360\CAM\cache\posts

You do this by clicking the three dots next to the machine this will open up machine library click on local and then the plus button that is above where all the machines would normally be.
Then go to post processing select the post processor you want
I hope this helps anyone who ran into the same problem I did
Edit: you might have to make the files read only to stop them getting randomly deleted (not sure).


Glad I ran across this thread, and thanks for posting the solution @cassuttaja. My pc just took a dump on me, and I regret to say I had a very poor backup plan when it came to f360, cura, light burn etc. I will have to re-earn the months of tuning on my printer lol, but at least with this f360 won’t be as frustrating to setup again.

1 Like

I am getting a Invalid post processor error when I try to install Flyfisher’s Post processor in Fusion 360 on my Macbook pro. Here are the details of my setup.

Fusion 360 2.0.15509 x86_64 [Rosetta 2]
Active Plan: Subscription
macOS 13.2.1 (22D68) on MacBookPro18,2


I’m not sure what java script file is being referred to in the solution post but no matter where I place the post file, I get the invalid error. Is there a newer post processor that people use or anyone else having this problem?


I ran a quick test just to make sure F360 had not broken something on my machine. I’m running Windows 10, not Mac, but have the same Fusion 360 version you list. My already-installed postprocessor works fine. Did you try importing the postprocessor from the post library?


Yes, that is how I tried to install it.

I just downloaded a fresh copy of the postprocessor, renamed it, and then installed it using the library icon. It worked fine. I’m running Fusion 360 2.0.15509 x86_64, which is the same one you list above. I’m on Windows 10, not Mac. All I can suggest are things you’ve probably already tried:

  • Download a fresh copy of the postprocessor
  • Open the postprocessor with a text editor and verify it looks like a clean text file
  • Install some other Fusion 360 postprocessor, then find it on your disk. Put the MPCNC postprocessor in the same place.

This is looking like some sort of Fusion 360 bug in the Mac version.

What did you rename it? Do I need to change the extension or something? I didn’t see instructions on needing to rename it so maybe I missed that.

Renaming had nothing to do with the success or failure of the install. I renamed it so that it would be installed as a new postprocessor. I didn’t want to delete my current postprocessor in case I also had the issue (and then would be without a postprocessor). I left the extension the same and just added “_test” to the base name of the file so the name became “MPCNC_Test.cps”.

Dan, was it ever working and a new version of F360 broke it or are you just trying to get started?

It’s been a couple of years since I’ve updated the post processor and I’ve never used it on a Mac.

Since the JavaScript of the post processor is just a text file my best idea is that it is a CR/LF issue. Macs and PC handle the end of each line differently. Sometimes when you download a text file the translation of these characters isn’t handled correctly - this happens most often when downloading to a Mac. If you open the post processor as a text file it should read as a multi line file. If everything is on one line then this is the issue.

Take a read of this article and see if that is the issue and if what they suggest can help.

1 Like