New build , Steppers sluggish

Hi everyone,
I am new here, and I just got my MPCNC built and I am doing the first test. when I try to move either axis X or Y one stepper moves before the other moves, I get a error on the screen showing "Printer halted . Kill () called.
I have tried to reflash the firmware using the latest on github (V1CNC_SkrPro_Dual_2209-2.1.1) and have the same results.

Any help you can give me would be greatly appreciated !!

Thanks Ron

I did a search of the kill-called posts on this forum to see if any seemed to fit your problem (stepper motor and kill issues both on a SKR Pro). Only found one…this topic. Towards the bottom of the topic, it was believed that the TMC driver was generating that error. There was no final resolution.

Reading between the lines in that topic suggests that:

  • A wiring problem to the stepper motor might cause this issue. You could run some check of the wiring using an ohmmeter. You are looking for shorts or continuity problems.

  • A bad stepper might cause this issue, but bad steppers are really rare compared to other components. You could use an ohmmeter to make sure you detect two, and only two coils.

  • Board soldering of the stepper socket might be an issue. We’ve seen a couple of boards on the forum where one of the sockets was incompletely soldered. In that case, it was obvious to a visual inspection.

  • I would swap stepper drivers on the control board from one of the poorly working stepper motors with one working well and retest. You want to see if the problem stays with the socket/wiring, or if the problem follows the driver.

  • Hooking your system up to Repetier-Host and duplicating it from there will give you more information from Marlin. Make sure error reporting is turned on in the log.

Thanks so much!! I will give this a try.

Can you check whether both motors move? This sounds like only one working stepper dragging the second one behind.

Sending M122 from a connected computer will tell you a lot if it is coming from the TMC drivers.

Thank you everyone for all of your help, I got it solved, apparently I am not smart and got the driver wires in the wrong order.