My Rambo hit it's first major snag.. help!

My Rambo board will not power on. The leds don’t light up at all. I am remaining outstandingly calm, all things considered but I’m more than a little worried. I have just the power supply hooked up, fed into the motors’ power ports and jumpered to the middle ports for the logic (etc.) exactly as it is pictured in the docs. Polarity is not the issue, and the psu is putting out 12v steady according to both my multimeter and the volt/ammeter readout I have wired to monitor the power output. The jumpered terminals are successfully being fed a steady 12v as well.
I tested the continuity of, and the voltage going through all 3 fuses – alas I discovered no issues on that front whatsoever. I have exhausted the resources at my disposal to no avail.

Here’s a better look at the board:

Have you tired measuring to see if there is power across one of the +5V pins on the board?
Because if there is power there, you at least know it’s getting through the board, but if theres nothing there it might suggest an issue with power getting to the board from the input terminals.

If none of the LEDs are coming on, then the logic section is not getting power.

There are 3 fuses

You will want to check F3 (Right next to the logic power input block) to make sure that it isn’t blown. Right next to that will be the 5V regulator, and you’ll want to be sure that also looks OK.

Aside from that, you can see if it will power up from the USB. Being connected to USB should bypass that input fuse and regulator, and power the 5V bus independently (I think. I don’t have one of these myself.)

I measured the aux out pins (to the left of Heat 0) which should have been 5v, but there was nothing. Next I tried the “motex” pin header, and none of the pins had a single volt of electricity. Then something strange happened

I touched point a with one probe, and b with the other and the board came on. It stayed on as long as I held the probes there. When I tried to repeat this there was a pop and now f3 no longer exhibits continuity so I think I blew it :confused: I emailed tech support at ultimachine so hopefully they can help

Were your probes in current measuring mode? They should be very high impedance. I don’t know the schematic well enough to know what A and B are.

I had it in continuity mode


I know right! I hope they can help me, I don’t want to drop another hundred or more dollars.

Update: ultimachine gave me the go ahead to send it in, I shipped it out today so fingers crossed it doesn’t take too long to make it home!

I had a similar issue a few months ago and it turned out something was up with the fuse and holder. The holder wasn’t pinching the fuse enough to complete the circuit. I bent the pins a little bit and it seems to be running ok so far.

I think my issue was most likely something similar. Hopefully I get it back and it just works