MPCNC RAMBo 1.4 board not connecting to PC

This thing will not connect to a pc or Mac. it works from the lcd but will not talk to the pc. Wtf am i doing wrong. Pictures and video will be supplied if requested for help. Please give a brother a hand.

Tried flashing the firmware to the board per V1s website. Visual Studio Code won’t even communicate with the board. Pc sees it, vs code sees it but will not actually talk to the board. Im thinking I might have a bad board. The lcd controller moves everything with no problem. I am looking for any help before I go and waste another 100 or more on a new board. I just want this thing to work. I am beyond frustrated.

I wouldn’t flash it yet. I don’t think it will help.

Is COM3 the right port? It may have “auto detected” the wrong thing. It shouldn’t be a big deal, since you won’t need vscode right now.

What are you using to try to connect? Repetier host, I assume? Here are some things to check:

  • make sure repetier server isn’t installed. It grabs the port and won’t let anything else have it.
  • baud rate should be 250,000
  • The port should disappear when you disconnect the USB. You can look in the device manager (in windows) or in dmesg (in mac, I assume) to verify which port is leaving.
  • Try a different USB cable
  • The board needs 12V when connecting via USB. I can see in your photo that it has that (the screen is on). Just don’t expect it to work if the screen isn’t working.
  • In old versions of windows, you needed a driver. Windows 7 or prior, I believe.

You can also try cncjs. There is a desktop version. Make sure you vhoose Marlin, disable hardware flow control, and set the baud rate to 250k.

I can’t flash it. It refuses to connect to windows. COM3 is the correct port. I verified in Device Manager. Repetier-Host is what I am using and I get connection error in there as well I’m pretty sure Repetier-Server is not installed. I am not home right now to let you know what the error is. I have tried 3 different USB cables all producing the same errors. I am pretty sure I have the correct drivers installed as well. Can take some more pictures to post when I get home. I can see an amber light on the RAMBo blink when I attempt to connect via Repetier-Host but receive an error and timeout. Baud rate is 250k as well.
I am just thoroughly frustrated with this board right now.

The baud rate for uploading firmware is different than the baud rate used by Marlin for communication. The bootloader expects 115200.

1 Like

Perhaps try a different device connected to your USB cable to prove the problem on or off your Rambo? Got a spare Uno or mega2560?

RAMBo 1.4 board still will not connect to Repetier-host and not even CNCjs. I’m thinking it’s shot. Like I said earlier. PC will see it. I see amber lights blink when I try to connect via Repetier-host but just get No start signal detected error message. Still looking for anything I can do. I am tempted to either buy a SKR Pro 1.2 or just see if I do anything from the SD Card slot. So frustrating. Thought this would actually be the easier part of the entire build.

Can you see anything being received in the console log in repetier host?

The lights may be lighting up from the serial port talk, and not feom the cpu (which may be dead, at this point).

Ryan used to sell ramps. But the quality control, especially for the cheap ones, is very low.

1 Like

I had similar problems with my ramps 1.4 (clone). What solved it for me was using a shorter usb-cable. The eBay-vendor recommended a cable shorter than 1 m. Tried it with a 15 cm cable and all connection-problems were solved. Maybe it’s worth a try.

1 Like

In the forum posts over the last couple of years concerning USB communication with a Rambo 1.4 board, it is exceeding rare for the problem to be traced to the Rambo board hardware. Usually, the problem turns out to be a bad USB cable, or some driver-like issue with Windows, or electrical noise, or a wrong baud rate, or a serial pin conflict, or…

If the board seems to be powering on okay, and you’ve eliminated all other possibilities, you could try a FT232RL USB to TTL Serial Converter Adapter Module. It connects to the TX0 and RX0 of the Rambo board, and if you go this route, I can provide a pinout diagram on how to do the hookup. This module would solve your problem if the issue is with the USB hardware and the Rambo board is otherwise good. I don’t think you can hookup the reset line to this board, so you will have to reset your Rambo board by hand at the right time to flash the board, but that is not a big issue, and the module will work fine (without doing anything special) for sending g-code over a USB cable.

It is rare to see a hardware failure on a Rambo board even when people do “stupid” things. On the other hand, if you purchased a clone Rambo board out of China, they have a higher incidence of being DOA.

1 Like

Board was purchased from V1. I wish I had someone local to put an extra set of eyes on this thing.

Did you install RAMBo USB driver?

Did you ever get a solution for this? I am having the same problem with a MakerGear M2 printer.