MPCNC has the Jitters

So I got my MPCNC moving. It seems to move OK without the belts attached, but when I move it with the steppers it seems to shake a lot. I do not have it anchored down yet so I am not sure if that is contributing to the issue. I have checked square and I am good on that. I do not think my belts are too tight. All of the tensioning bolts are very loose (X and Y only finger tight). I do notice that when I grab on of the roller assemblies I can move it about 1/16 - 3/32 on the conduit and the other end is stationary. It appears to pivot around the center assembly.

Anyone have any ideas?

Your belts look a little loose, but pretty close.
Try moving it from a computer instead of the LCD screen it seems to be moving/accelerating it too fast. If your conduit is really rough you can sand it a bit with some 220 and it might help.

It behaved the same when I ran it out of Repetier Host. I did it from the LCD for the video as it was easier to get long runs without traveling too far.

I will tighten up the belts a little bit. I know I read where the belts are supposed to be loose so I did not want to over tighten them. The conduit is a little rough. I have some fine sandpaper / emery cloth so I will give that a try as well.

Thanks for the pointers.

The LCD and repetier pretty much run it at max speed. When running slower it should be really smooth. I would load up a test file and see how it runs. The belts should be a bit tighter though.

I will give that a try. I tightened up the belts, “polished” the conduit, tightened the middle assembly just a touch, and one of the roller blocks just a bit.

Seemed to be a little better but I noticed one point in the motion where it was bad. It appears that I managed to get the seam next to the bearings and there is a little rough spot. I will work on that area a little bit and also run a program. I really need it to stop raining here so I can get my bench top and finish this thing up.

Thanks again

OK. So I have tightened the belts some, polished the conduit, rotated conduit so no seams on the bearings, checked for square, and now have it attached to a table.
I have check vRef (.7, .71, and .4). I did a test run of a circle with the shown Tool from Estlcam

I am still not getting a smooth operation.

Not sure what to try next.



The first 2 screenshots don’t apply to us, just the one with the red. It looks pretty smooth have you tried it with a pen yet? I think your belts are still a little loose or maybe that’s what happens when you make it so big, the fluttering.

I realized my video showed the belts fluttering which is not really the issue. The head of the unit shakes. So tonight I did a large rectangle pattern to see if it just needed “breaking in”. I noticed that it got a lot worse at the edges. I stopped the pattern and noticed that the middle rails are not parallel to the side rails. Both x and y. I took all of the rail system apart and started from the beginning. The outside rails equal distant apart and square to within 1/32". With out any belts attached the short rail is 1/4" off from end to end. I measure 8" gap on one side and 8-1/4" on the other side. I try to make it even, but I can see my middle assembly twisting. If I anchor one end and pull the other end even, it will relax to about an 1/8" to 3/32" off but any slight bump and it goes back to the 1/4". It appears that my middle assembly is not perfectly square. I do not see where I can really adjust this.


I should also mention I tried with the long bolts in the assembly tight, snug, and loose and it sis not seem to have any effect.

The second video does appear to be smoother in operation, but. You need to tighten those belts up. If your X and Y axis are not running perpendicular to each other and/or not parallel to the side rails. This should only effect the job, not cause the jittering that is being transmitted down the belts.

Have you tested the driver output voltage for both the X and the Y. I’m thinking that either one is running under powered. Try upping the voltage slightly to see if that makes any difference. But keep feeling the drivers heat sink, to ensure that they do not get to hot, while testing.


Here is a video of the latest motion after putting it all back together.

Has this gotten any better? The only other thing I can think of is the roller long bolts being way too tight. Do they move smooth by hand or can you feel the same grinding?

So hard to long distance trouble shoot I wish I could just come and look at it I could have you up and running in a few minutes I’m sure of it.

It has gotten a little better by tightening up the belts significantly. The biggest issue I think I have is in the y axis (short rails in my setup). The rail that travels with the middle assembly is not parallel to the other 2 (out by 1/4"). I have checked and the ends are parallel to each other, and my assembly is square. The only thing I can think of is the rollers are not sitting on the rails correctly for some reason, or the middle assembly is not quite square. I checked as best I can with a carpenters square and it looks OK, but it would not need to be off much for 1/4" difference over 24".

I have loosened all of the long bolts that I think would help to the point where I can turn them by hand, rollers and middle assembly. I even loosened the bolts in the middle assembly that hold the two halves together. I also tried to “jump” some teeth in the belts to square it up, but the rail just springs back.

I did a test plot of some diagonal lines, curves, a circle and a square (did not take video) and the plot came out looking good. My square (about 2"x2") was square as well. I believe for my initial usage it will work fine.

I will keep tweaking and trying things on it, but I will be out of town 3 of the next 4 weeks. When I get back next weekend I will do some more plotting and take some close up video.

When you measure your frame across the diagonal in both directions you get the same number? that is the only way your rollers can be off by 1/4" yet you still cut a perfect square not a parallelogram.

The diagonals are within 1/32" of each other. The lengths and widths match as well. The 1/4" dimension is from the outer short rail to the short rail on the middle assembly. I am thinking that is causing the shaking as it might be binding the roller assemblies on the rail.

That can’t cause the shaking unless one of your steppers is not working.

Draw or cut a large square and check it’s diagonals. If they are within a 1/32nd" leave it be. There is nothing else to check. If you are cutting a perfect square, your steppers are all powered , your rails are smooth, your belts are properly tensioned, nothing is wrong other than you can see it shake. One of those has to be the problem, or there is no problem?

Is that shaking only when you control it with the lcd? When you run gcode does it work fine?

Was out of town last week so am just getting back to this. I have tightened up the belts more and the shaking has seem to resolved itself. Top of the Z tower shakes a little bit but I suspect that is normal.

I drew several shapes and curves on a test piece, but by large rectangle is off square by quite a bit. The one picture shows the measured dimensions (to my best estimate on the corner that did not get drawn). The dashed lines are the orientation of the middle y rails to the outer y rails (see previous post by me). The out of square matches the direction of the non parallel middle rails if that makes sense.

I was reading some of the other threads on being out of square so I took the middle assembly off and see that it is not square, bit I am not sure how to fix this.

That’s going to have nothing to do with your issues. No ones parts are perfect. They are 3D printed. Edges like that have no bearing on a design like this. So long as all your bolts and bearings line up, the outside of your prints not being square will have NOTHING to do with your device being square. The issue is your device isn’t square. Or your electronics are not working properly, or your belts are loose, mis-tightened, one side is tighter than the other, causing flex under tension of the motors…they’re are a million reasons why it’s not acting correct. You could have a bow in your pipe that you can’t see…Your outside frame should be dead nuts with Ted’s new corner pieces. Your Z should be square and rugged with his new Z assembly.

So I decided to disassemble the MPCNC and assemble the gantry from the beginning. The first thing I checked was getting the middle rails parallel without belts and the middle assembly. I noticed right away that the middle Y rail would not stay parallel to the outer Y. My X and Y lengths match, and my diagonals are within 1/32" so I am guessing that one of my Rollers is slightly skewed causing this issue. I tried the bolts really loose, just snug, and tight in all the various arrangements (inner bolts tight outer loose, flipped, at diagonals, etc.) and nothing made a difference. I am thinking some sanding is in order to get this parallel and start from there.

I also made some “squaring arms” for when I put the belts on to make sure I do not skew it then as well.

Yes I would say try sanding the rollers, This just came up for someone else in the forums recently. Looks Like I will be remaking the rollers soon…

Don’t worry about the belts being square they can move independently.