MP3DP Repeat V2 (aka V4) z steppers

Around the beginning of December ('22) I finished by MP3DP V4 build – it’s my first MP3DP and my first CoreXY. So far I’m loving it – works like a champ.

One thing that bugs me, and I suspect this is the same for the v3, is that when the steppers are disabled the bed comes flying down to the bottom. Right now I’ve got my pause, cancel, and end gcode lowering the bed to the lowest possible point, but it doesn’t cover every case. For example, I just started a print, had a slight issue so I cancelled. Then I went to start again with the bed raised, and my X endstop failed. Klipper freaked and the bed had a 230mm freefall.

I’ve been trying to find a way to avoid it that isn’t software driven, but so far I’ve got nothing. Would love to hear any ideas anyone may have.

1 Like

I’ve been looking at that.

Not so much an issue on my Repeat, but the addrd mass of 3 Z motors seems to add some potential energy into the mix.

The problem is knowing when the steppers are energized. I don’t know of any condition that the firmware can act on when they aren’t and certainly not when the firmware panics on a failed check like endstips, or thermal runaway when it basically shuts off.

Thinking now, that might be the trigger, that it shuts off, maybe can tie in to the stepper driver enable pin. Put a brake on the Z axis, and if there is power to the stepper enable pin, release the brake. A manual release as an override. I don’t know how much current can be drawn there, i wouldn’t want to do more rhan a logic trigger from the enable pin. It shuts off fans then, too, maybe a fan circuit can release the brake…

Well, since I don’t even try messing with stuff like resuming failed prints, I may just take an old fashioned mechanical approach and put soft springs under the Z motors to keep them from a hard impact if they drop…

It’s all conjecture at this point, the last pieces for my build (2020 extrusion corner braces and slide nuts) are in customs now, and I only have half the parts for a V4 printed. I decided to give up on a milled frame pretty much last minute.


Some sort of cushion at the bottom of Z axes makes a lot of sense. I just threw away something that probably would have worked perfectly.

I had a blast building mine, especially with step by step directions (like when I built my MPCNC). Just using the CAD and what I knew about printers (and a little help from Ryan) to end up with a usable machine is just awesome.

Sorry no ideas for original question, but this sounds like good info for the docs.

Also sounds like a fun practical project. Curious what print speeds (and extruder, layer depth, nozzle size, etc…) folks are able to reliably push with their MP3DP v4 builds?

I’ve not pushed the limits yet, and I tend to be pretty conservative with speed settings. For example, on my Cartesian Ender5, I tend to max out around 80 mm/sec, and those slicer profiles were my starting point on the V4. That said, last night, I was printing a license plate frame, so it had some pretty long stretches. Klipper was showing that I maxed out around 95 mm/sec (with the slicer profile kicked up to 100 mm/sec). Klipper was also estimating that I’d be able to get up to 150 mm/sec reliably.

That print was using a Hemera extruder printing PETG from a 0.4mm nozzle at a .28mm layer height.

I’ve got one final issue to solve on my V4, and then I’m going to try pushing the speed. I’m thinking a XYZ calibration cube scaled up to 200 mm^3 with 0 infill and no top layers. I figure I’ll set the slicer to 150mm/sec, and then keep pushing the speed up manually during the print. I’m hoping to be doing that this weekend.

1 Like

An option:

I finished my one thing sooner than expected, so I did an initial test last night. I was printing PETG at 0.28mm, with the nozzle at 240 and the bed at 90. I decided to print the square that Klipper uses to calibrate pressure advance, scaled up to 200x200mm. My build area is ~235x235, so that felt like the right size.

I copied an existing profile in SuperSlicer, and changed the speed settings to look like this:

  • Default speed: 150 mm/s. (percent speeds below are from this number)
  • Perimeter speed: Internal 100%, External 62.5%
  • Travel Speed: 150 mm/s

I also disabled machine limits in the slicer. I sliced the model with 0% infill, 2 perimeters, 3 bottom layers, 0 top layers. In Klipper, max velocity was set to 300.

Once the 3 base layers were done, I increased the speed to 110%. I was seeing actual speeds of 165 mm/s for traveling, and around 83 mm/s when printing straight lines. 83 doesn’t sound like a lot, but it looked like it was flying. In the picture, the corners at the lowest layers look like absolute trash. I’m not sure why. Also the sides bulge out some. I suspect that is because I was using PETG with thin walls, and it’s often suggested to print PETG slower than PLA. But this is a test, right?

The corners cleaned up when I got up to 150% and I starting seeing print speeds in the low 100’s. When I kicked it up to 175% the corners look even tighter. Even at 200% things still looked pretty solid, and klipper was reporting back print speeds of right around 145 mm/s. I thought the damned hot end was gonna fly right off the rails.

At this point, the UI was telling me that I couldn’t increase the speed factor anymore because I had hit the limit configured in the printer config. I did find a way to change the printer config mid-print, so I kicked the machine limit up to 600 mm/s. Having done that, I set the speed to 250%. This is where things went off the rails. It was probably too big of a jump. I tried to bring it back to 225%, but by the time I got the change made, it had already printed 2+ layers. I think at 225% (so ~337 mm/s) the print would have held and been OK. Not great, but good enough for a prototype.

This is the first time I’ve ever tried something like this, and I pretty much guessed my way through it. Next time around, I’ll probably do some research to make sure I understand the slicer speed settings properly, as well as the klipper settings.

Update: The corners look so bad on the bottom because of the model. It was printing a corner in mid-air. The model obviously wasn’t designed to be scaled like that.

1 Like