MarlinBuild again

I’m pretty sure that’s exactly how most of us feel. Replace “github” with “cnc” and “update” with “project”, and reread that.


I have the “500” in the author and the machine tag. I can’t figure out how to get it back from the firmware though.

On the Skr pro, at least, pronterface doesn’t print the whole huge list at startup. It just prints ~.

Neither screens, or M115, or M503 shows me the Ryan, or 500 in a string.

What am I missing?

I wonder if I need to swap these:

Did you get the one in src/inc/version.h I am not seeing it in the configs. They all three (places I put the version number) show up in different places.

Ah, ok. I see a SHORT_BUILD_VERSION that isn’t in my configs. I think I can still just add that to the config files, and not have to sed the inc directory.

I was going to try and be helpful, and try to put together a mapping for @buildlog’s ESP32 MPCNC board for Marlin, just to have a build for it. But I can’t seem to figure out how the pins are mapped by inspecting the Marlin ESP32 implementation and the Grbl_Esp32 code, and I realized I’d also have to implement dual endstop squaring using a single pin. Not impossible, but a bit more than I was looking to do…

Ah, green builds :smiley:

Marlin merged my PR into bugfix, and the ramps and rambo builds are working again.

I also saw some tweets about them updating the runners (it looks like it was an accident?) so I might have to try the composed actions again. But I am working on a sand ify release this week. So maybe next week.


Now I really need to step it up and get this all incorporated into the docs.

So…I made a pre-release to tag the builds and get the newly fixed ramps and rambo in. The good news is it worked, super simple! Bad news is somehow in the actions tab everything is called 503??? I left it on the main branch, but I changed these two fields to v503, and selected pre-release at the bottom.

Made a post asking for testers.

Oh and Still no notifications. I added my email to notifications in the settings tab for this repo but it was while it was building so maybe it will send them to me next time?

The tag should be just the three digit number 503. The title should be much more descriptive, and it can be changed. The tag needs to stay the same though. Adding something like (Needs testing) or [BETA] will help people scroll down to one labelled Stable. But it won’t be important until we actually have something stable.

I only get emails when they break. So you might have to make a PR with something wrong to test the emails.

1 Like

Composites are officially released, so I guess I should try it again:

Nevemind. It doesn’t support ‘uses’… So basically not at all useful. Darn.

Hi @jeffeb3, can i have some help please?

I’m trying to get marlinbuilder working form myself, and i think its super cool! but i also want to change it a little to be able to do other builds as well (like for my printers)

problem is, i’m smart enough to copy and paste stuff, but not smart enough to understand what i fucked up when i encounter error messages… I tried google, but im not even sure what to google for, so was hoping for some help. Im assuming im doing something pretty basic wrong, but some pointers (or even just some search terms to use in the google to find what i need etc?)

Where I’m getting stuck is im trying to run some new config files, and it comes back as an exit code 126, permission denied

++ opt_set CUSTOM_MACHINE_NAME '"Anet A6 86ef837DL"'
[52]( /home/runner/work/MarlinBuilder/MarlinBuilder/src/configs/common/ned-base-config
[53]( line 11: /home/runner/work/MarlinBuilder/MarlinBuilder/src/configs/common/ned-base-config: Permission denied
[54]( Process completed with exit code 126.

Which happens when i try and run the ned-base-config file, which is an exact copy of the v1-base-config and wont work.
Am i missing some kind of permission something for a new file? I’m so confused. Im also not a very avid user of github, so im not sure if the problem lies with my files, with my github setup, or the actions files, or something else…

I’ve tried different permutations of files and names and what not for the last few hours, and am stuck now.

Any pointers?

1 Like

Did you make these folders/files on a windows machine (or even more specific using sourcetree)?

I have that issues sometimes and I have to run a permissions command in a terminal. Before uploading


Github runs these on a linux machine. Text files can’t be executed like a program unless they have the execute permission for the user who is trying to run them. Git doesn’t keep track of most permissions, but it does keep track of the x bit. I don’t use windows, but you need to find a way to set the x bit and then commit that to the repo.

Some hacky workarounds:

  • you can change one of the other files instead of making a new one
  • you can make one of the first steps in the process add the x bit to all the files. Something like:
    chmod A+x common/ned-base-config

These aren’t as good long term for your project, or for your personal linux learning journey, but this repo won’t be used by hundreds of people and you can learn the right way later.


I did, yeah…

Thanks, I’ll have a google! or if you see this before i figure it out, what command do you use?

Cheers! those two replies will at least give me enough to know what direction to google in!

Ok, just posting this here for the next person (or for when i forget in 3 days)

C:\git\MarlinBuilder\src\configs\common>git update-index --chmod=+x ned-base-config

That did the job for me, thanks guys, chased my tail for a bloody long time there haha


Me too! HEffe gave me that same tidbit, and it did work. Now I try to copy and rename as many files as possible (nothing from new).

1 Like

you know what i like best about marlinbuilder? its faster to compile on the cloud than my laptop