Marlin 513S not reading SD Card

Hi All,
We have the V1 CNC Router built and operational. It operates correctly when “driven” from a laptop. When we try to get it to run a job from an SD Card (4GB Fat32 format with only 2 gcode files in one folder and nothing at root directory), the LCD displays “Media Inserted” but does not do anything else to allow us to select the gcode file.
We have flashed the firmware and updated the u8glib file to uncomment the #define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER (both suggested elsewhere in the forums). I saw a screen shot elsewhere in one of these forums that shows a small icon on the LCD that looks like an SD card. Our display does not show that icon. After posting this, I’ll try uploading a picture of what it does show. Per another posting, we have tried inserting the SD Card before powering up the LCD and controller with no difference except that it does not show “Media Inserted”.
Advice or suggestions welcome and appreciated.


To to be clear, to run from an SD card:

  • press on the knob on the display to get to the main menu
  • scroll to the bottom to the “Print from Media.”
  • Press the knob to select the sub-menu
  • Scroll to the file you want to run
  • Press the knob to run that file
  • Scroll away from “Cancel”
  • Press the knob to run

It sounds more complicated than it is. Are you doing any of these steps? If so what happens? If Marlin cannot find the card, the last menu item will say “No Media.”

1 Like

Hi Robert,
Thanks for the response. I added a picture of the LCD. It has a knob at the bottom right that can be turned but apparently not pressed. I tried restarting the device, then inserted the SD card and tried pressing that knob. It seemed to have no effect on the display. Also, there was no feeling of anything being pressed. Is that the knob your post refers to?

The knob on the lower right is the one I’m referring to. When I press my knob. there is an distinct feeling of a switch being activated, and a dull click, and, when powered, there is a quick “tick” from the speaker as well. I’ve owned two of these displays and have done personal electronics using rotary encoders that have a button like the one in the display. They all give a bit of physical feedback when the knob is pressed to indicate the button is activated.

Since you have a 3D printed case and knob, my first suggestion is to remove the knob and try just pressing on the stem to see what happens. If the knob is too tight to the case, it might be preventing the stem from going down far enough to click the button. If it still does not activate, then I would remove the display from the case and try just the display. Note you should be able to feel the button activating even when the display has no power.

If you cannot get a “click,” then the rotary encoder is probably bad. If you get a click but it is not recorded by the firmware, then I would check for bent pins on either the back of the display or the control board where these cables connect.

If it turns out to be a bad display and you either cannot return it, or don’t want to wait the time to return it, they are available for around $15 on Amazon from multiple sellers.

Hi Robert,
I removed the 3D printed knob and that was it. Many thanks! Without the plastic knob there, the stem works correctly as you described.