Marcos 4x4.

Hello Guys, I almost have my 4x4 MPCNC ready.

Buy everything in the vicious store, I have a laptop with windows 10, I followed the instructions to the letter.

My problem lies in one of the Nema 17 engines of the Y axis. The movement of the shaft does not work, and probe changing the wiring for a new one that I buy here on the page …it only moves on the X axis

Did someone have a similar problem? It’s like the engine was dead.



something else, I have an LCD with card input, as I can add it to the board, so everything is handled from the controller and I do not use the PC.




What control board?

That is a different LCD you will need to edit the firmware to use it.

1 Like

Hi Ryan , the board is RAMP 1.4 / DRV8825 drivers .

Did the other Y axis motor still work? Have you tried plugging it into another port, to see if it’s the drv8826 or the motor? Don’t swap the cables while it’s powered.

1 Like

Thank you very much, all the engines are running. I had to change one, it did not work.

My problem now arose with the Repetier-Host ", I charge the G code that I export using Estlcam \ V10, I give it to print and nothing happens.
The machine does not move, it connects but it does not move.

Connect it to the Estlcam and it works, it moves correctly.
but nothing happens with the Repetier

EstlCAM can’t connect to Marlin, so it sound like you programmed the Arduino with the EstlCAM software. You will either need to program the Arduino with the Marlin software or use EstlCAM to run the job. Repetier only connects to 3d printer software like Marlin.

1 Like
Thanks for your time. Estlcam, I really like it is very intuitive and it looks very complete for the ability I have now.
Try all night to send a job from my PC to the Mpcnc using it ... I could not ... I do not see where it says to launch the work ...I read all this post. Very good...

I highly recommend you do it this way.


The “first use” paragraph, gives a complete walk through. You will need to put my firmware back on though, since you have probably flashed the board without knowing it.

1 Like

I’m following everything as it says, I do not know where I’m failing.

Arduino: 1.8.4 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

C:\Users\MCana\Downloads\MPCNC813_GLCD\MPCNC813_GLCD\MPCNC813_GLCD.ino:45:110: fatal error: U8glib.h: No such file or directory

#include <U8glib.h> // library for graphics LCD by Oli Kraus (


compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

You missed the first two steps on my firmware page that have pictures. You did not install the ug8lib.

1 Like

Now try as it says following all the steps, keep sending me the same ERROR.

However I could download and load the Marlin 1.6 without any problem, connect it to the repetier and send it a G file, it worked more or less well, it moves like a 3D printer, using the Z axis.




Not ug82…The one under it. Look at the steps one more time.

1 Like

Ok, thank you very much, I’m an idiot, i look, but I did not see.
Apologies. It’s working, now the problem I have is that I run out of space on the board as I can eliminate space or delete everything from the board in order to load what I’m missing

Scroll up, that is then end of an error message, you have only used 40% of free mem. That is how it looks when it is successful. I don’t know what the error is. Have you tried it does it work?

1 Like


I go straight to the machine to test if it works




already working and loading the codes, the problem I have now is that it moves from the work area, I travel from the center to a corner, and started working in that area.

Reset the arduino after you have placed the head and before you hit start.

1 Like

I appreciate the time you take to respond.

I’m having the following problem, in Repetier, when I want to position my head, it just lets me move a few millimeters for one side, but then it does not let me return, or it just lets me return the same amount that I moved to the other side.
I can not use the entire space …

I reloaded the firmware, but this time the, MPCNC813_GLCD_T8,
Something improved, I can control the machine.
My problem now is that the z axis, when moving does not rise, continues cutting until the drawing begins.
Following tutorials to see what I find …

I would like to know how to position a table and frame those measurements to cut inside it.

Be safe, use a pen not a power tool until the machine works as you expect.


To me it looks like you have CAM issues. Follow my tutorials and make sure everything works as it should. I include gcode to compare to. It should be identical. All cuts can be simulated with a pen, at the bare minimum use foam not wood, you are likely to break something this way.

1 Like