Mac user thwarted by kill pin - HELP

Hey guys just set up my mpcnc last night - I got everything moving, but as i went to draw the crown i noticed that my endstops (that i havent wired yet) weren’t letting the cnc move properly and I also can move in a - direction. So I went to the github to get the firmware and reverse my endstops’ boolean to true and since I am a mac user i changed my baudrate to 115200 for safe keeping. (ive since reset to 250000)

Now the problem that im having is the motors dont move at all and the kill pin is active and throwing an error.

I tried to change everything but the endstop values back and nothing helped.

I then cloned the repository and checked out “” figuring that is the version that cam on the Rambo 1.4 board that i bought.

Now I keep getting the error about the darn kill pin!

I even went into pin_Rambo.h and set the Kill_pin -1 from 80 and that didnt seem to help at all.

I’ve tried using Pronterface and Repetier Host so far.


can any one help me get this thing working again (but fully)



This red light is new “the red light of DOOOOMMMM!!”

The red light usually means you have the wrong firmware on there.

Triple check you downloaded the correct firmware from my github and flash it as is with zero modifications first. Uninstall and reinstall repetier, it looks liker you have made some changes that I do not think you should have made. This should work, stock as is, no changes. The baud rate thing was from old MAC’s as far as anyone could figure out. You have made a lot of changes and are on a MAC so this is territory that is slower for me to spot obvious problems. Start fresh and see what happens.